Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1507
  • Last Modified:

Can't switch from GUI to text login from Console

After my SCO system boots up, the first screen displayed at the console is the GUI login.  In the past, I could use CTRL-ALT F2 and switch to a "text" based login, or multiscreen login.  However, something has happened to cause only the SCO help screen (which only describes how multi-screen logins work) to display when using this key combination.  So, I cannot use a text login from the console at this point, which is a real pain.  This happened over a weekend.  The system was up, but to my knowledge no one was even logged on.

0
Geoff Freeman
Asked:
Geoff Freeman
1 Solution
 
yuzhCommented:
Normally, you can use "<Alt><Ctrl><Fn> to switch to a different multiscreen,
then <Alt><Ctrl><F2> to return to tty02 where the X server is running. Your video display should be back to normal.

If it doesn't work, have a look at /var/adm/messages file to see if there is any error messages.

or try to reboot the box to see if it can fix the problem.
0
 
Geoff FreemanV.P.Author Commented:
First, reboot did nothing.  Second, I can't switch screens using the keyboard selections, which is the whole problem.  Although I didn't see error messages in /var/adm, I did see several of the following in syslog:
Jun 10 07:51:32 scosysv telnetd[8298]: unable to write terminal control database entry for line ttyp2
Jun 10 08:19:14 scosysv telnetd[15561]: unable to write terminal control database entry for line ttyp29
Jun 10 08:28:34 scosysv telnetd[8469]: unable to write terminal control database entry for line ttyp4

Is the a correlation between the problem and these messages perhaps?
0
 
yuzhCommented:
try the followings to see if you can fix the "terminal control database" problem:

login as root, type in:
1) make up the difference /etc/inittab terminal control database defined tty equipment , type in:
# ttyupd

2)fill in the missing database pseudo-ttys control terminal (/dev/ttyp?)
 /tcb/bin/ale /etc/auth/system/ttys pttyupd

then
reboot
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
burrcmCommented:
At a root prompt, type scologin disable to turn off the gui autostart permanently (scologin enable to reverse). At a root prompt, type startx to start a gui session as required. Much easier to manage.

Chris B
0
 
Geoff FreemanV.P.Author Commented:
That works fine because the GUI really isn't used at all!!
0
 
Logic Managed ITSystems AdministrationCommented:
I would suggest that the <Ctrl> key wasn't working for some reason.
The only way to activate the GUI multiscreen Help window is by pressing <ALt><F2> thru <Alt><F10>
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now