Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5725
  • Last Modified:

Opening txt files from web automatically in notepad

Hi!

I am trying to open txt files from web automatically in notepad e.g i want this link to open in notepad instead of Internet explorer. : http://www.whitehouse.gov/robots.txt

Thank you
A
0
itscdoorway
Asked:
itscdoorway
  • 2
  • 2
  • 2
1 Solution
 
bluefezteamCommented:
Well that's because IE sees this as a document it can open itself as it's a recognised filetype in the shell sysyetm and IE is a compatible program.

With .net from memory you can use the code below to show IE it's an attachment and it should open an external program, but that's if you are making your own page to serve txt files...

Also this has been recommended as a solution for your own machine, but it won't do it on everyone elses unless they follow the instructions...

"The "Browse in same window" option for the file extensions for ".txt" is
disabled. But after I delete the "TXT" file extensions and recreate the "TXT"
file extensions and set configure "notepad" to open it. The plain txt will not
use IE to open. It is prompted to use notepad to open the txt file."

This means you need to remove the filetype .txt from your list of know file types and then re add it but only list notepad as a compatible file - not everyone is will to do that; but if this is a problem just for you and your PC - try it.
Do you have the http-header Content-Disposition=attachment ?
 
Response.AppendHeader("Content-Disposition", "attachment");
 
or even
 
Response.AppendHeader("Content-Disposition",
"attachment;filename=file.txt");

Open in new window

0
 
jcimarronCommented:
itscdoorway--I assume when you say "open...automatically in Notepad", you mean when you click on a .txt file.  
Change the association of .txt files so they open in Notepad.  Right click on any .txt file|Open With|Choose Program (even if you see Notepad in the first group of programs offered).  Highlight Notepad, check the box at the bottom left "Always use the specified program to open this kind of file"|OK.
0
 
bluefezteamCommented:
Well that's pretty much what I said 'file association', the problem being is that as the file is a file associated with Explorer, even though it's not the primary program (ALWAYS USE) it's still associated so explorer opens it.

What's needed is to remove internet explorers association completely to a TXT file so it doesn't presume it can open it to save the user and system time opening another program.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
itscdoorwayAuthor Commented:
This didn't help, I tried to associate the txt file to ONLY be opened with notepad. Tried access http://www.whitehouse.gov/robots.txt again, but still the txt file is opened in IE. I also tried to delete the txt under file types, but still it's opening in IE...
0
 
jcimarronCommented:
itscdoorway--On my PC, .txt files are set to open with Notepad (Windows Explorer|Folder Options|File Types).  If I click a .txt file already on my hard drive it opens, as it should, in Notepad.  If I click on a .txt link in an IE page, however, it opens, as you say, in IE.  
If nothing else works, a simple work around is to right click .txt files in webpages|Open With and cick Notepad.
0
 
itscdoorwayAuthor Commented:
Or simply open the link with .txt ending in IE and right click in the "txt file"  then choose "View source" :)

Thanks for the tip jcimarron, that was the little tip I needed.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now