Solved

Configuring IIS 5.0 to read PHP

Posted on 2008-06-11
2
469 Views
Last Modified: 2013-12-13
What I'm trying to do:
Setup a database on my webserver that communicates via PHP.
Where I'm at: I've setup IIS 5.0 on my advanced server 2000 home server.  I've downloaded and installed mysql 5.0.  I've downloaded and installed PHP 5.2.6.

I try to run a test phpinfo() page at the end of my local host, and can't see anything.  I have no idea how to integrate PHP 5.2.6 with IIS 5.0 on my server.  Where do I go from here?  I am so tired of trying to figure this stuff out until 4 am, it's frustrating beyond all belief.  Please help!
0
Comment
Question by:ASC_FULFILLMENT
2 Comments
 
LVL 5

Accepted Solution

by:
mms_master earned 500 total points
ID: 21777956
Hi,

Try this:
--------------------------------
Configure IIS to use PHP
--------------------------------

When you open IIS Manager, it should connect to the local computer automatically.
Expand the local computer in the left pane
Click on "Web Service Extensions" in the left pane
In the right pane, click the blue underlined text, "Add a new Web service extension..."
Enter "PHP ISAPI Extension" as the "Extension name"
Click the "Add..." button and browse to the php5isapi.dll file in your PHP install folder
Check the "Set extension status to Allowed" checkbox and click "OK"

--------------------------------
Add PHP file extention (.php)
--------------------------------

Expand the local computer in the left pane
Right-click on "Web Sites" in the left pane, then click "Properties" in the menu that pops up
Flip to the "Home Directory" tab
Click "Configuration"
Flip to the "Mappings" tab
Click "Add..."
Enter the full path to php5isapi.dll in the "Executable" textbox (Browse... to find it more easily if you need to)
Enter ".php" in the "Extension" textbox
Select radial button "Limit to", enter "GET,POST,HEAD"
Click "OK" all the way out

--------------------------------
Turn on scripting permissions
--------------------------------

Right-click on "Web Sites", goto Properties -> Home Directory.
Change the "Execute permissions" dropdown to "Scripts only".

mms_master
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will explain how to display the first page of your Microsoft Word documents (e.g. .doc, .docx, etc...) as images in a web page programatically. I have scoured the web on a way to do this unsuccessfully. The goal is to produce something …
Generating table dynamically is the most common issue faced by php developers.... So it seems there is a need of an article that explains the basic concept of generating tables dynamically. It just requires a basic knowledge of html and little maths…
Learn how to match and substitute tagged data using PHP regular expressions. Demonstrated on Windows 7, but also applies to other operating systems. Demonstrated technique applies to PHP (all versions) and Firefox, but very similar techniques will w…
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now