Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1316
  • Last Modified:

suse keyboard layout

this is my first contact with installing linux.
cant seem to get croatian keymap work in suse 10.3, gnome
i want english language and cro keymap.
under keyboard preferences i have cro layout.
everything works fine in my x, but when I browse to some flash web pages, or use irc clients, or use rdp client keymap is not working fine.


0
fokuszg
Asked:
fokuszg
  • 4
  • 3
1 Solution
 
MicheleMarconCommented:
yast2

Select "Hardware" on the left side and then "Keyboard Layout" on the right side. Change the keyboard layout and save the settings with "Accept".
0
 
fokuszgAuthor Commented:
keyboard layout is croatian, as i selected it during install.
0
 
ridCommented:
Very generally, I'd  be inclined to suspect that a correlation between language and KB layout would be the best setup; i.e. Croatian language and ditto KB layout.

It may help if you describe in what way you feel things don't work well. Normally, I use a swedish KB layout and swedish language and I can view all web sites well, but when I try to enter special swedish characters, they don't always work out OK. I will then be forced to work with english/US character set only, avoiding my national specials. That is easy, as the US/english charset is a subset of the swedish charset; I just avoid åäö... Is your situation different?
/RID
0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
fokuszgAuthor Commented:
i dont like the translations, first they are uncomplete and second, some things are just better left in english.
so croatian language is out of the question.
basically the same situation, i just thought there would be a solution to this, nothing is unsolvable, i can go past a few web sites that wont work well. but its annoying to work with remote desktop and get everything scrambled when typing on the remote machine.
0
 
ridCommented:
So, what, more precisely, is not working? Characters typical to croatian (I guess there are diacritics for s and c and other things like that), or is the entire KB badly mapped? Some KB layouts come in varieties, like dvorak, qwerty and azerty.

When you do remote desktop, are the machines involved on UDF-8 both?
/RID
0
 
fokuszgAuthor Commented:
yes, in web pages only diacritics.
remote desktop seems to work fine with diacritics, but special characters are as if on qwerty keyboard, except the ones that are in places of diacritics, those i have yet to find :)
remote machines are win 2k3 with croatian kb layout.
0
 
fokuszgAuthor Commented:
i tried changing /etc/sysconfig/keyboard to use croat.map.gz, but i presume it is only related to text console?
also is /etc/sysconfig/language related to text console or? what would it effect to leave lang=en_US and changing everything else to croatian?
>locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
is it possible that rdp client uses these settings?
i am new to linux, so maybe these are all stupid questions :)
0
 
ridCommented:
Well, this web site, too, has problems with certain characters with diacritics (e.g. latvian , a, etc), but åäö seem to work, so I guess this is a complex problem. There was a thread about it here (which I started) and one comment suggested that characters described as "double-byte characters" were giving trouble. How the problem occurs in dealing with remote desktop on another O/S is really not something I've looked into at all.

Just for fun, you can start a program called "xev" in a terminal window on your Suse machine. This program will analyse your keypresses and tell you what your local system thinks each key should represent, like this:

KeyRelease event, serial 28, synthetic NO, window 0x2c00001,
    root 0x4c, subw 0x0, time 2077613863, (283,473), root:(288,521),
    state 0x0, keycode 45 (keysym 0x6b, k), same_screen YES,
    XLookupString gives 1 bytes: (6b) "k"

KeyRelease event, serial 28, synthetic NO, window 0x2c00001,
    root 0x4c, subw 0x0, time 2077702458, (620,549), root:(625,597),
    state 0x2080, keycode 39 (keysym 0x1b9, scaron), same_screen YES,
    XLookupString gives 2 bytes: (c5 a1) "a"

Note the line "XLookupString..." which talks about 1 or 2 bytes; 2 bytes are connected with special characters (in this case an "s" with a small angle above it, normally it comes out weird on this site).

Running xev will tell you if your characters come out OK on the local machine, which is a good start. If they don't, you may have to try varieties of the croatian KB layout (if any) to get things right.

Sorry I can't give you a proper solution.

/RID
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now