Solved

how to configure cisco 2801

Posted on 2008-06-11
34
5,105 Views
Last Modified: 2011-10-26
hi everyone i have i have just bought a 2801 cisco router i want to configure it as
192.168.10.1

i want to configure the NAT on this router
0
Comment
Question by:ammartahir1978
  • 20
  • 12
  • +1
34 Comments
 
LVL 2

Expert Comment

by:sofianshibani
ID: 21757977
does it have any extra modules, what interface you need to configure with this ip?
post the running configuration, i'll modify it and post it back
0
 

Author Comment

by:ammartahir1978
ID: 21758055
its new i have connect the console cable to the serial port how can i connect to tit
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21759009
Plug the blue cable into your PC's com port and the other end into the console port of the router.  Open hyper terminal using  these settings 9600,N,1 then hit enter a couple of times and you should connect.

Once you've connected to the router, power cycle the router.  When it reboots it will take you into setup mode.  Once you've done that we can help you config the rest.  
0
 

Author Comment

by:ammartahir1978
ID: 21759419
when you say power cycle the router?

i am on the command line now, how can i check what is the ip address of this router right now.

thanks
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21759460
if you're at a # prompt, type:
sho conf

If an interface is configured you'll see something like:
interface FastEthernet0/0
 ip address aaa.bbb.ccc.ddd xxx.xxx.xxx.xxx

By power cycle I mean, turn off the power then turn it back on.
0
 

Author Comment

by:ammartahir1978
ID: 21759490
okay i have run the comand and it came up with

INVALID INPUT DELETE AT '^' maarkar

i will power down now
0
 

Author Comment

by:ammartahir1978
ID: 21759502
just rebooted its load stuff
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21759551
Did you get a prompt asking if you want to go into setup mode?
0
 

Author Comment

by:ammartahir1978
ID: 21759570
sorry forgot to tell that when i restarted it took me to the command prompt LTSCISCOSDSL>
0
 

Author Comment

by:ammartahir1978
ID: 21759587
no i go directly to the command prompt
0
 

Author Comment

by:ammartahir1978
ID: 21759600
is there any command which i can use to see what is the current IP address like in windowns you have ipconfig
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21759610
type en at the > prompt, this should give you an enable prompt #, then type sho conf

0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21759684
0
 

Author Comment

by:ammartahir1978
ID: 21759988
thanks for this but i can not change the ip address as it say invalid on marked

i tried

enable
configure terminal
ip address 192.168.10.1 255.255.255.0
and on this command it says
invalid at marked ^ and the mark is on p

what to do
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21760033
Assuming interface fa0/0:

routername>en
routername#conf t
routername(config)#int fa0/0
routername(config-if)#ip address 192.168.10.1 255.255.255.0

then do a control-Z to exit config mode
routername#wr mem


0
 

Author Comment

by:ammartahir1978
ID: 21760179
okay i have done it but i can not ping 192.168.10.1
what to do now
0
 

Author Comment

by:ammartahir1978
ID: 21760187
i cant even telnet as i am connected thorugh the blue cable do i have to connect through ethernet cable?
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:ammartahir1978
ID: 21760209
one more thing when i do ip on prompt it comes up with

translating "ip" domain server (255.255.255.255) why is that as were i have 255.255.255.0
0
 

Author Comment

by:ammartahir1978
ID: 21760338
okay i have connected a laptop to the router and i can access the router through web but its not going in i mean loggin in as i am using the same password which i used to connect through blue cable
0
 
LVL 16

Accepted Solution

by:
2PiFL earned 500 total points
ID: 21760371
To stop it from trying to resolve ip addresses type:

routername#conf t
routername(config)#no ip domain-lookup

control-z, then:

routername#wr mem

Yes, you need an ethernet cable to connect via telnet.  If you're plugging the PC directly into the ethernet port of the router you will need a rollover cable.
0
 

Author Comment

by:ammartahir1978
ID: 21760468
okay i have done it but when i connect it through http://192.168.10.1 it ask me fr passord and login when i use the one i try to connect to terminal service it doesn allow me in

is there anyother passowrd?
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21760869
the default password is cisco
0
 

Author Comment

by:ammartahir1978
ID: 21761024
got that now
how can i set up NAT TABLES and Access list to the mail shot server whose ip address is 192.168.10.226
0
 

Author Comment

by:ammartahir1978
ID: 21761042
how can i open port 25 in the router
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21761158
do a #sho conf and copy it here.
0
 

Author Comment

by:ammartahir1978
ID: 21761770
Hi 2PiFL

this router is purely used for mail shots and the linux box which is running postfix has ip address 192.168.10.226 and i also want 192.168.10.20 to be authorise, i want telnet and smtp on mailshot.domanin.com please help
Using 1802 out of 196600 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname LTSCiscoSDSL

!

boot-start-marker

boot system flash:/c2801-ipbasek9-mz.124-15.T.bin

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

ip cef

!

!

!

!

no ip domain lookup

ip domain name LTS

multilink bundle-name authenticated

!

!

!

!

!

username Administrator secret 5 $1$jDvx$YcJZoDrTBV8ncQUcgnLA/.

archive

 log config

  hidekeys

!

!

controller DSL 0/3/0

 mode atm

 line-term cpe

 line-mode 2-wire line-zero

 dsl-mode shdsl symmetric annex B

 line-rate auto

!

!

!

!

interface FastEthernet0/0

 description LTS LAN

 ip address 192.168.10.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface ATM0/3/0

 no ip address

 atm ilmi-keepalive

 pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

 !

!

interface Dialer0

 ip address negotiated

 encapsulation ppp

 dialer pool 1

 dialer-group 1

 ppp authentication chap callin

 ppp chap hostname S8-248@intralan.net.uk

 ppp chap password 7 154412040A322F367D

!

ip route 0.0.0.0 0.0.0.0 Dialer0

!

!

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

dialer-list 1 protocol ip permit

!

!

control-plane

!

banner login ^CConfigured by Intralan 08447707000^C

!

line con 0

 exec-timeout 0 0

 password 7 154412040A322F367D

 logging synchronous

 login local

line aux 0

 password 7 124F1C1F1C1308167F

line vty 0 4

 privilege level 15

 password 7 124F1C1F1C1308167F

 login

 transport input telnet

line vty 5 15

 privilege level 15

 password 7 14410B03021C2E3971

 login local

 transport input telnet

!

scheduler allocate 20000 1000

end

Open in new window

0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21762405
Can you give us a block diagram of your network and where this router will be?
I'm not sure why you would need NAT.
0
 

Author Comment

by:ammartahir1978
ID: 21762580
Network is


CISCO ROUTER

LINUX BOX (RUNNING MAIL SERVER)
WORK STATION DIRRCTLY CONNECTED TO THE ROUTER (192.168.10.226)

i need smtp port open on this workstation
i need telnet port for thei s workstation also
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21762743
Like this?

192.168.10.20
     |
   WS-----Router-----Linux Box (192.168.10.226)
              |
    192.168.10.1
0
 

Author Comment

by:ammartahir1978
ID: 21762760
yeah

192.168.10.220 ---->- relay email on 192.168.10.226 -------> send out through ------>192.,168.10.1 router
0
 

Author Comment

by:ammartahir1978
ID: 21762940
this is how it was on previous router if thats helps
nat-setting.jpg
0
 
LVL 16

Expert Comment

by:2PiFL
ID: 21774462
                                           192.168.10.1 interface
                                           |
Workstation-------------------Router----?
(192.168.10.20)            |
                                     |
Linux box                      |
(192.168.10.226---------

This is the way I read your last post, I apologize for not understanding but could you rephrase your request?
0
 

Author Comment

by:ammartahir1978
ID: 21779334
thats fine 2PiFL,

192.168.10.1 (Router) connected to SdSL line
                                     |
Linux Box-----------------------------------(connected to Router)
(192.168.10.226)

                           |
                          |
                          |
                         |
Workstation
(192.168.10.220)


so workstaion send emails to Linux box and then linux box send it out to clients through router.

hope this explain but right now no email is going out of Linux box
0
 
LVL 2

Expert Comment

by:litmuslogic
ID: 21810165
amma, let me see if I understand.  You want someone on the other side of the router to be able to specify 192.168.10.1 as their mail server and have the mail deliverd to 192.168.10.226 instead?  That someone being either a user with a mailbox on .226, or some other server attempting deliver to .226?  

BTW, what is on the other side of the router?  An ISP?  Another site?  Corporate network?  I am asking because I am trying to understand exactly what we need to translating into what, if that makes any sense :)
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now