Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

DCOM Event viewer errors, please help :)

Posted on 2008-06-11
5
Medium Priority
?
869 Views
Last Modified: 2011-06-03
I keep getting these errors can some please help rid my event viewer of these.

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
 to the user DYFLIN-EXCHANGE\IUSR_DYFLIN-EXCHANGE SID (S-1-5-21-1723704571-2642521685-794025816-1003).  This security permission can be modified using the Component Services administrative tool.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
Comment
Question by:nostrasystems
  • 3
  • 2
5 Comments
 
LVL 8

Accepted Solution

by:
greesh_hem earned 2000 total points
ID: 21759648
This problem may occur if either of the following conditions is true: . A
program with the class ID (CLSID) that appears in the message tries to start
the COM component by using the DCOM infrastructure. However, the user does
not have the required permissions to start the COM component.
.. The Network Service account does not have the correct permissions.

To fix the issue:
To resolve this problem, use one of the following methods, depending on the
cause of the problem.
Back to the top

Grant the user permissions to start the COM component
Grant the user permissions to start the COM component. To do this, follow
these steps: 1. Click Start, click Run, type regedit in the Open box, and
then click OK.
2. Locate and then click the following registry subkey:
HKEY_CLASSES_ROOT\CLSID\CLSID value
Note In this subkey, "CLSID value" is a placeholder for the CLSID
information that appears in the message.
3. In the right pane, double-click AppID.

The Edit String dialog box appears. Leave this dialog box open and continue
to the next step.
4. Click Start, click Run, type dcomcnfg in the Open box, and then click OK.

If a Windows Security Alert message prompts you to keep blocking the
Microsoft Management Console program, click to unblock the program.
5. In Component Services, double-click Component Services, double-click
Computers, double-click My Computer, and then click DCOM Config.
6. In the details pane, locate the program by using the friendly name.

If the AppGUID identifier is listed instead of the friendly name, locate the
program by using this identifier.
7. Right-click the program, and then click Properties.
8. Click the Security tab.
9. In the Launch and Activation Permissions area, click Customize, and then
click Edit.
10. Click Add, type the user's account name, and then click OK.
11. While the user is selected, click to select the Allow check boxes for
the following items: . Local Launch
.. Remote Launch
.. Local Activation
.. Remote Activation

12. Click OK two times.
13. Quit Registry Editor.

Back to the top

Grant the correct permissions to the Network Service account
To grant the correct permissions to the Network Service account, follow
these steps: 1. Click Start, click Run, type dcomcnfg in the Open box, and
then click OK.
2. In Component Services, double-click Component Services, and then
double-click Computers.
3. Right-click My Computer, and then click Properties.
4. Click the COM Security tab.
5. In the Launch and Activation Permissions area, click Edit Default.
6. Click Add, type Network Service, and then click OK.
7. While Network Service is selected, click to select the Allow check boxes
for the following items: . Local Launch
.. Remote Launch
.. Local Activation
.. Remote Activation
Click OK two times.
0
 

Author Comment

by:nostrasystems
ID: 21760016
I have followed this and can see the object but what permissions do i need to set as it looks to have similar permissions the service it launches is called "msi server"
0
 
LVL 8

Expert Comment

by:greesh_hem
ID: 21769726
0
 

Author Comment

by:nostrasystems
ID: 21924128
what user account name do i use?

9. In the Launch and Activation Permissions area, click Customize, and then
click Edit.
10. Click Add, type the user's account name, and then click OK.
11. While the user is selected, click to select the Allow check boxes for
the following items: . Local Launch
.. Remote Launch
.. Local Activation
.. Remote Activation
0
 

Author Comment

by:nostrasystems
ID: 21924156
stupid question :) got it sorted :)
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
On September 18, Experts Exchange launched the first installment of the Help Bell, a new feature for Premium Members, Team Accounts, and Qualified Experts. The Help Bell will serve as an additional tool to help teams increase question visibility.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

885 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question