Help configuring Windows Server 2008 MTU size to work with Linksys router

At work we have a Windows Server 2008 server and I am having problems accessing its websites from home.  At home I am behind a Linksys Wireless Router that apparently has a max MTU size.  I think the problem is that the packets that the server sends to the router are too large and they are getting dropped because the browser just kind of stops while saying "Waiting for www.whatever.com" and eventually times out.  If I take out the router and connect directly to my cable modem, I can access the websites.  My question is how to configure the server so that it send proper size packets because I imagine that many people have a linksys router and cannot access our site.
MarkAOlsenAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Michael WorshamConnect With a Mentor Infrastructure / Solutions ArchitectCommented:
Another thing you can do on the Windows Server 2008 side is this:

In the console enter the following commands to change the MTU:
netsh interface ipv4 show interfaces

Take note of the id number of the wireless interface (as you will need it below), then do:
netsh interface ipv4 set subinterface id mtu=1492 store=persistent
0
 
Michael WorshamInfrastructure / Solutions ArchitectCommented:
Which Linksys router do you have at the server-side site?

Most Linksys-side MTU settings for handing websites is 1492, however this depends solely on your Internet connection (i.e. cable, DSL, etc), not on your server-side handling rate.
0
 
MarkAOlsenAuthor Commented:
Actually, the server is behind a NETGEAR ProSafe VPN Firewall FVS388.  Could that be causing the problem?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Michael WorshamInfrastructure / Solutions ArchitectCommented:
Do you have TCP port 80 opened to the outside world so that it can be seen?

A quick way to test is to try 'telnet www.sitename.com 80' and see if it connects.
0
 
MarkAOlsenAuthor Commented:
Yes, 80 is open and I can access the web site from most places.  I think the netgear is the problem in that it may be sending packets that are too large.  I'm going to do some experimenting when I get home (at work now) and see if lowering the MTU on the netgear will solve the problem.  If it does I will close the question.
0
 
MarkAOlsenAuthor Commented:
Interesting solution to this one.  I had the HyperV RC role installed on the server and removed it the same time that I lowered the MTU on the interface.  It appeared that the MTU solution was what made me able to see my websites from anywhere but now I believe it was the uninstallation of the HyperV server role because I reinstalled it and the problem started happening again and it was fixed when I uninstalled it again.  So basically, I don't think the MTU solution worked and if anyone else comes upon this problem and they have HyperV installed, uninstall it and see if it helps you out.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.