• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 332
  • Last Modified:

Roaming Profiles and Folder Redirection

I set up roaming profiles to work with folder redirection, and it works fine.... for new users.
It works with all test users I created after I set the policy, but not with any already existing users.

The path for the profiles is correctly configured at \\server\profiles$
The folder redirection path is correctly configured at \\server\redirect

I have My Documents redirecting to \\server\redirect\%username%
I have Desktop and Application Data redirecting to \\server\profiles$\%username%

I changed the profile path on the test users to  \\server\profiles$\%username% and connected the U:/ to \\server\redirect\%username% and the folders for that user are automatically created in those locations.
When I do the same with an old existing user, My Documents redirects perfectly but Desktop and Application Data do not redirect, nor does it create a new folder at \\server\profiles$

What permissions/settings should I implement to get the old profiles redirecting to \\server\profiles$?
  • 2
  • 2
1 Solution
If the roaming profile is situated at \\server\profiles$ and Folder Redirection is sending the data to the same place, then you will see the behaviour which is occurring. You are trying to redirect the Desktop and App Data back to themselves - a pointless operation. You should simply set those entries in Folder Redirection to "Go to local userprofile location" - that's the only option to use in order to get them to go to the profiles share.

I would recommend you send the Desktop and Application Data elsewhere, since redirecting to the profile means they will make the profile huge. I usually use \\server\redirect\%username%\Settings\App Data and \Desktop for these folders.
bci231Author Commented:
The problem we have with that is, we don't want the end users to have access to Desktop and Application Data in case they feel like messing everything up.
We only want them to be able to see "My Documents."

So would you agree that we should just make a new hidden share for desktop and app data?
Yes, either a new hidden share specifically for those folders, or you could change the My Documents redirect so it points to \\server\redirect\%username%\Documents, then use \App Data and \Desktop within the redirect share. Since the documents is going to \Documents, they won't see the other folders.

It's up to you which option you use - either a separate share or changing the My Docs redirect; both will work equally well.

bci231Author Commented:
Made the share, tested it, everything works fine now.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now