How to add a Windows 2008 Terminal Server to "Connect to my company's application-sharing server"

I am trying to add a Windows 2008 Terminal Server to "Connect to my company's application-sharing server", but have not been able to.

In the past I have always ran the http://sbsservername/connectcomputer script on terminal servers to add them to the remote web workplace application-sharing server section, but with Windows 2008 you can not run this script. The script tell you that it does not support this version of Windows.

Does anyone know how I can get a windows 2008 terminal server to show up in the "Connect to my company's application-sharing server" section of a SBS 2003 server?
mcmincAsked:
Who is Participating?
 
tigermattConnect With a Mentor Commented:
I wouldn't expect it to appear in the RWW because it's not actually being joined to the SBS network in the usual method through the /connectcomputer wizard. At present, it's not possible to join a Server 2008 machine to an SBS network using the wizard until an upgrade is released. The easiest way in this case to access the server is to manually log in to it using MSTSC.EXE (Remote Desktop Connection).
0
 
tigermattCommented:
You need to manually add the Server 2008 machine to the domain as the connectcomputer wizard does not yet support Server 2008. As you don't want it to be a Domain Controller (since it is a Terminal Server), you can simply open System properties in Control Panel, Advanced System Settings, Computer Name, Change, choose "Domain", enter your SBS domain name and press OK. Provide Administrator credentials when prompted and restart the server.

A static IP address must be set on the server and the only DNS server must be set as preferred with the IP to the SBS server ONLY.

This article confirms this, although you don't need to run adprep or dcpromo as the server will not be a Domain Controller. http://blog.mpecsinc.ca/2008/04/sbs-server-2008-mysbsconnectcomputer.html

-tigermatt
0
 
mcmincAuthor Commented:
I have tried these steps and the windows 2008 terminal server does not show up in the remote web workplace.

Is there anything that needs to be refreshed? I have already flushed the DNS on both servers.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
mcmincAuthor Commented:
Tigermatt,

I have done everything you suggested and rebooted both server, but still do not see the Windows 2008 terminal server listed in remote web workplace.

I do see the server listed in Active Directory Users and computers, it has a static ip on the SBS subnet, it is using the SBS server as is sole Primary DNS server.

Does anyone have another suggestion?
0
 
mcmincAuthor Commented:
Does anyone have any idea how to solve this problem?

Possible through a registry entry or something?
0
 
Rob WilliamsConnect With a Mentor Commented:
I'll back up tigermatt on this, it's not an option to date with 2008. As far as I am aware it's not actually added to a list but rather searched and located each time using the following file. C:\inetpub\remote\client.aspx  I know there is an entry in there that if you remove it stops searching for any active terminal servers. I suspect the flag it is looking for is not present in 2008. That is just a guess on my part. I am not a programmer.
0
 
Rob WilliamsCommented:
Thanks mcminc.
Cheers !
--Rob
0
 
Rob WilliamsCommented:
Sorry, I didn't notice the 'C' grade. That is quite disappointing and definitely not as per EE guidelines.
--Rob
0
 
mcmincAuthor Commented:
The grade should have been a B, sorry.
0
 
mcmincAuthor Commented:
More detailed answer would have qualified as an A.
0
 
tigermattCommented:
How can the answer be made more detailed? I specifically provided a reason why it cannot be done - the connectcomputer wizard is not being used - and I also detailed a workaround in the mean time.

"I wouldn't expect it to appear in the RWW because it's not actually being joined to the SBS network in the usual method through the /connectcomputer wizard. At present, it's not possible to join a Server 2008 machine to an SBS network using the wizard until an upgrade is released. The easiest way in this case to access the server is to manually log in to it using MSTSC.EXE (Remote Desktop Connection)."

I don't understand how - without spending hours researching the RWW and writing an essay - I could have been more descriptive?
0
 
productivetechCommented:
I had the same issue where we recently added a 2008 Terminal Server to our SBS 2003 network and it was not showing in the list of Application Sharing Servers in RWW.  While researching the issue on-line I found this thread which said it could not be done at this point in time.  Discouraged, I decided to continue searching to see if I could find another answer and I did.  I tried it and it worked so I thought I'd post what I found here

Rob Will's comment saying "I suspect the flag it is looking for is not present in 2008" was right on.  But I found you could add the flag manually to make SBS 2003 RWW detect the 2008 Terminal Server by adding the following registry key:

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TerminalServer\TSEnabled
Type: REG_DWORD
Data value: 0x1 Enabled
Data value: 0x0 Disabled

Here is a link where I got that information from:
http://forums.techarena.in/small-business-server/1015603.htm

I hope this helps.

John
0
 
Rob WilliamsCommented:
Thanks very much productivetech for pointing this out. Good information to have. It appears to be very new information, 2 weeks ago. I was already able to make use of it in another thread:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_23670036.html#a22300374
Cheers !
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.