Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 837
  • Last Modified:

Spooler problems

I am running Windows XP SP2. My printer stopped working and was removed from the list. I have tried all the solutions on the other posts but when i try to start the spooler it says path not found. I used the cleanspl.exe program and it could not finish for the same reason. I check the registry key and the
path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Spool\Imagepath does not exist.
The program spoolsv.exe was not in system32 folder i replaced that but can not change the path to executable in teh services tab.
0
sdcgibbs
Asked:
sdcgibbs
  • 5
  • 4
1 Solution
 
b0lsc0ttCommented:
Is that the only printer you have installed?  If not, do other printers have the same problem?

If it is just one printer and others work then did you delete the printer from Windows and reinstall it?  Let me know if you have a question about this.  It may also help if you elaborate on the other solutions you tried.  I don't want to tell you stuff you already did. :)

bol
0
 
sdcgibbsAuthor Commented:
I also had other printers running on a network that i can no longer access. The printer is gone from windows i used the driver disk and uninstalled but it says it can not complet do to the spooler not running when i try to install it again it say RPC i not functioning. I have turned RPC off and then back on and it still does not let me install. I checked the system32 file and spoolsv.exe was missing. I copied the file from I386 and put it back in system32 folder. In services i goto printer spool and the executable path is blank so it is not accessing the new spoolsv.exe file i replaced. How do get the printer spool service to let me input a new executable path?
0
 
sdcgibbsAuthor Commented:
I down loaded the cleanspl.exe program but that will not function with the spool not running. I have seen other post say to make sure that the imgpath folder is there on the reg keys but no solution if it is not there.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
b0lsc0ttCommented:
I can look for some steps to just fill in that field or you can wait to see if another expert provides them but if that is missing I would seriously consider a Repair Install.  I am not a fan of that option unless needed and it definitely isn't something I use or suggest often.  However something messed up the service and my experience says there are usually other problems.  XP's repair install is good and easy.  Let me know if you are interested and have a question about it.

Let me know what you think of this.  I assume you mean the setting in the image below for Path to executable is empty, unlike the image below.

bol
SpoolerService-XP.png
0
 
sdcgibbsAuthor Commented:
Yes that is what is missing. I was going to try and do a repair. But i ordered my computer from dell and did not install xp. I enter my password for the reinstall but it does not except it.I can not find any other admin passwords in the books that came with my computer.
0
 
b0lsc0ttCommented:
You might try to leave the password blank.  When does this password appear?  Which edition of XP (i.e. home or professional)?

Which model of dell is your computer?  I am not an expert on working with their computers but most manufacturers put some recovery method on the computer instead of giving you the OS CDs.  If you have a problem or can't find it you may need to contact Dell but I can try to provide details if you give the full model and family for the computer.

bol
0
 
sdcgibbsAuthor Commented:
i tried leaving the password blank and it didnot except it. I am using XP Professional and i am using the Dell Vostro 1000.
0
 
b0lsc0ttCommented:
If you can't figure out the password then you will need to try to reset it.  The  steps at http://www.petri.co.il/forgot_administrator_password.htm seem to be very successful at letting you do this.  Once you do it then proceed with the repair.

Let me know if you have a question or need more info.

bol
0
 
b0lsc0ttCommented:
A repair was the fix for this (or full, new install).  The Asker got stuck because of an Admin password on the OS but this can be closed with an answer.  I recommend http:#a21782787 .
bol
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now