Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1680
  • Last Modified:

New *Now Setup - Service Unavailable when calling out

THE PROBLEM:
-------------------
 I cannot place any outgoing calls on our new T1 line. I can call other extensions without any trouble.


THE SPECS (most of them copied and pasted from the GUI):
------------------------------------------------------------------------
Asterisk 1.4.18.1 (running AsteriskNOW - the 64-bit version)

Wildcard (Digium) TE121 with VPMADT032, Card 1 - Port undefined (span_1) - current config:
   Alarms: OK
   Framing/Coding: ESF/B8ZS
   Channels: 23/24 (T1)
   Signalling: PRI - CPE
   Switch Type: National ISDN 2 (default)
   Sync/Clock Source: 0
   Line Build Out: 0 db (CSU)/0-133 feet (DSX-1)
   Channels: Use 23

The server is plugged into the local network as 192.168.1.80, and we hacked together a T1 crossover cable to connect it to the Cisco hardware router that came with the new T1 line. I watched the T1 tech guy place an outgoing call using his toolkit after installing everything, so I know outgoing is working.

THE SETUP SO FAR:
-------------------------
I went to the shell, SU-ed to root, and ran register, then registered 23 channels for G.729 codec (purchased from Digium today).

I've set up one user (extension 1109 - I changed the starting extension range to 1000) in the system and used the X-Lite softphone on my desktop to successfully log in.

I've also been able to use X-Lite to dial 1109 and also dial 7000 (the default IVR). Both extensions connect successfully.

I've updated the Calling Rules in the GUI to look like this:
International - begins with 9011 and followed by 7 or more digits - Call using Span 1
Local - begins with 9 and followed by 7 or more digits - Call using Span 1
911 - begins with 911 anad followed by 0 or more digits - Call using Span 1
Longdistance - Begins with 91 and followed by 10 or more digits - Call using Span 1

I've set up one Incoming Call rule to point to the default IVR.

The /etc/asterisk/zapata.conf file contains almost nothing. It just looks like this:
[trunkgroups]
[channels]

Here are the last several lines from the Asterisk Logs after a reboot:
[Jun 11 14:56:08] NOTICE[4187] loader.c: 1 modules will be loaded.
[Jun 11 14:56:08] NOTICE[4187] cdr.c: CDR simple logging enabled.
[Jun 11 14:56:08] NOTICE[4187] loader.c: 158 modules will be loaded.
[Jun 11 14:56:08] NOTICE[4187] res_odbc.c: Adding ENV var: INFORMIXSERVER=my_special_database
[Jun 11 14:56:08] NOTICE[4187] res_odbc.c: Adding ENV var: INFORMIXDIR=/opt/informix
[Jun 11 14:56:08] NOTICE[4187] res_odbc.c: res_odbc loaded.
[Jun 11 14:56:08] NOTICE[4187] config.c: Registered Config Engine odbc
[Jun 11 14:56:09] ERROR[4187] res_config_pgsql.c: Postgresql RealTime: Failed to connect database server asterisk on 127.0.0.1. Check debug for more info.
[Jun 11 14:56:09] WARNING[4187] res_config_pgsql.c: Postgresql RealTime: Couldn't establish connection. Check debug.
[Jun 11 14:56:09] NOTICE[4187] config.c: Registered Config Engine pgsql
[Jun 11 14:56:09] WARNING[4187] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Jun 11 14:56:10] WARNING[4187] pbx.c: Unable to register extension 's-BUSY', priority 1 in 'macro-trunkdial', already in use
[Jun 11 14:56:10] WARNING[4187] pbx.c: Unable to register extension '_s-.', priority 1 in 'macro-trunkdial', already in use
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: Starting AEL load process.
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: AEL load process: calculated config file name '/etc/asterisk/extensions.ael'.
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: AEL load process: parsed config file name '/etc/asterisk/extensions.ael'.
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: AEL load process: checked config file name '/etc/asterisk/extensions.ael'.
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: AEL load process: compiled config file name '/etc/asterisk/extensions.ael'.
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: AEL load process: merged config file name '/etc/asterisk/extensions.ael'.
[Jun 11 14:56:10] NOTICE[4187] pbx_ael.c: AEL load process: verified config file name '/etc/asterisk/extensions.ael'.
[Jun 11 14:56:10] ERROR[4187] chan_misdn.c: Unable to initialize mISDN
[Jun 11 14:56:10] NOTICE[4187] codec_g729a.c: G.729 transcoding module version 35, Copyright (C) 1999-2007 Digium, Inc.
[Jun 11 14:56:10] NOTICE[4187] codec_g729a.c: This module is supplied under a commercial license granted by Digium, Inc.
[Jun 11 14:56:10] NOTICE[4187] codec_g729a.c: Please see the full license text supplied by the accompanying
[Jun 11 14:56:10] NOTICE[4187] codec_g729a.c: "register" utility, or ask for a copy from Digium.


And that's where we are right now. I'm not sure what to do next.
0
gr8gonzo
Asked:
gr8gonzo
  • 6
  • 2
1 Solution
 
Joel_SiskoCommented:
At the command line run this:

asterisk -vvvvvvc | tee /tmp/debug.log

Upload the result to this post.


Joel Sisko
0
 
gr8gonzoConsultantAuthor Commented:
Asterisk 1.4.18.1, Copyright (C) 1999 - 2008 Digium, Inc. and others.
Created by Mark Spencer <markster@digium.com>
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
  == Parsing '/etc/asterisk/asterisk.conf': Found
  == Parsing '/etc/asterisk/extconfig.conf': Found
Asterisk already running on /var/run/asterisk.ctl.  Use 'asterisk -r' to connect.
0
 
gr8gonzoConsultantAuthor Commented:
Both of the files mention in the output are almost all commented out. The asterisk.conf file had a [directories] section that had some entries and the rest of the file was commented out. The extconfig.conf file was completely commented out except for the section header [settings].
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Joel_SiskoCommented:
Ok, so Asterisk is starting.

type at the asterisk command line: zap show channels

Also zapata.conf will need something like this listed under the configured T1 card:

switchtype=national
context=from-zaptel
group=0
signalling=pri_cpe
channel => 1-23

Joel

0
 
gr8gonzoConsultantAuthor Commented:
Here's the output:
Command> zap show channels

   Chan Extension  Context         Language   MOH Interpret      
 pseudo            DID_span_1                 default            
      1            DID_span_1                 default            
      2            DID_span_1                 default            
      3            DID_span_1                 default            
      4            DID_span_1                 default            
      5            DID_span_1                 default            
      6            DID_span_1                 default            
      7            DID_span_1                 default            
      8            DID_span_1                 default            
      9            DID_span_1                 default            
     10            DID_span_1                 default            
     11            DID_span_1                 default            
     12            DID_span_1                 default            
     13            DID_span_1                 default            
     14            DID_span_1                 default            
     15            DID_span_1                 default            
     16            DID_span_1                 default            
     17            DID_span_1                 default            
     18            DID_span_1                 default            
     19            DID_span_1                 default            
     20            DID_span_1                 default            
     21            DID_span_1                 default            
     22            DID_span_1                 default            
     23            DID_span_1                 default  

The zapata.conf was almost completely empty except for section headers, so there was no T1 configuration in there. However, I did a grep in /etc/asterisk and users.conf had this:

[span_1]
switchtype = national
signalling = pri_cpe
trunkname = Span 1
trunkstyle = digital
hassip = no
hasiax = no
group = 2
context = DID_span_1
zapchan = 1-23

The users.conf file also had my extension in there as well as a "general" template for creating new users. Here was my extension config:

[1109]
callwaiting = yes
cid_number = 555-5555
context = numberplan-custom-1
email = (my email)
fullname = Jonathan H
hasagent = yes
hasdirectory = yes
hasiax = yes
hasmanager = yes
hassip = yes
hasvoicemail = yes
deletevoicemail = no
host = dynamic
mailbox = 1109
secret = 1234
threewaycalling = yes
vmsecret = 1234
registeriax = yes
registersip = yes
macaddress = (my desktop's MAC address, since I'm using a softphone)
autoprov = yes
label = 1109
canreinvite = no
nat = no
dtmfmode = rfc2833
disallow = all
allow = all
signalling = fxo_ks

I configured this user through the *Now GUI.
0
 
gr8gonzoConsultantAuthor Commented:
I added verbose and dtmf to the logging and reloaded the logger, then tried to make a call. Here's what got put in the logs (I changed the actual digits to # just for here):

[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Executing [91##########@numberplan-custom-1:1] Macro("SIP/1109-00751950", "trunkdial|Zap/g2/1##########|") in new stack
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Executing [s@macro-trunkdial:1] Set("SIP/1109-00751950", "CALLERID(all)=Jonathan H <5555555>") in new stack
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Executing [s@macro-trunkdial:2] Dial("SIP/1109-00751950", "Zap/g2/1##########") in new stack
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Requested transfer capability: 0x00 - SPEECH
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Called g2/1##########
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Zap/1-1 is proceeding passing it to SIP/1109-00751950
[Jun 12 09:00:49] VERBOSE[4584] logger.c:     -- Channel 0/1, span 1 got hangup request, cause 1
[Jun 12 09:00:49] WARNING[9429] app_dial.c: Unable to forward voice or dtmf
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Hungup 'Zap/1-1'
[Jun 12 09:00:49] VERBOSE[9429] logger.c:   == Everyone is busy/congested at this time (1:0/0/1)
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Executing [s@macro-trunkdial:3] Goto("SIP/1109-00751950", "s-CHANUNAVAIL|1") in new stack
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Goto (macro-trunkdial,s-CHANUNAVAIL,1)
[Jun 12 09:00:49] VERBOSE[9429] logger.c:     -- Executing [s-CHANUNAVAIL@macro-trunkdial:1] NoOp("SIP/1109-00751950", "") in new stack
[Jun 12 09:00:49] VERBOSE[9429] logger.c:   == Auto fallthrough, channel 'SIP/1109-00751950' status is 'CHANUNAVAIL'
0
 
gr8gonzoConsultantAuthor Commented:
One additional note - I tried dialing from outside INTO the PBX using one of the numbers that came with the T1 line, and it went through just fine. So dialing IN works - just not dialing OUT.
0
 
gr8gonzoConsultantAuthor Commented:
Turns out the telco hadn't enabled outbound dialing yet on our T1 line.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now