[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Does anyone have a working sample config for wireless bridging?

Posted on 2008-06-11
7
Medium Priority
?
2,170 Views
Last Modified: 2013-11-09
I have a couple of Cisco 1300s here. I'm trying to test turning them into a wireless bridge to extend a LAN to a remote location. Right now they are under my desk. They are both connected to a switch along with my laptop so I have LAN access to them. I'm trying to get them to talk to each other to no avail. One thing I see is that on the workgroup bridge, the radio interface stays in "reset" state and whenever I make a change, the console logs this message:
%DOT11-2-UPLINK_FAILED: Uplink to parent failed: Unsupported authentication type

Here are the current configs. I know IOS very well but I'm not too versed in wireless and APs. What am I missing?

AP2 (root):
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap2
!
enable secret Cisco
!
no aaa new-model
!
!
!
dot11 ssid 1300
   accounting acct_methods
   guest-mode
   infrastructure-ssid
   information-element ssidl wps
   no ids mfp client
!
!
!
dot1x credentials ap2
 username mbernhardt
 password mbernhardt
!
username Cisco password Cisco
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 ssid 1300
 !
 antenna gain 10
 power local 5
 power client 5
 station-role root bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 172.30.52.53 255.255.255.0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!        
!
!
line con 0
line vty 0 4
 login local

AP1 (remote bridge):
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap1
!
enable secret Cisco
!
no aaa new-model
ip domain name br
!
!
!
dot11 ssid 1300
   accounting acct_methods
   guest-mode
   infrastructure-ssid
   information-element ssidl wps
   no ids mfp client
!
eap profile ap2
 method md5
!
!
!
dot1x credentials ap2
 username mbernhardt
 password mbernhardt
!
username Cisco password Cisco
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 ssid 1300
 !
 antenna gain 10
 power local 10
 power client 10
 station-role workgroup-bridge
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 172.30.52.52 255.255.255.0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
 login local
line vty 0 4
 login local
0
Comment
Question by:mikebernhardt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 3

Expert Comment

by:shroomduck
ID: 21763468
SSID's have to be the same, do not broadcast them. And im not sure with the 1300's but you may need to run another AP off of the AP/Bridge as I am almost certain they cannot function as both.
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 21763498
SSIDs are the same, look at the configs. I don't want them to function as AP at all, I just want to extend a LAN wirelessly.
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 21763516
Oh- and I have looked at several cisco.com pages and not found what I need. If someone has a working configuration for both roles (root bridge and whatever the other side needs to be) I would appreciate it!
0
Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

 
LVL 10

Expert Comment

by:atlas_shuddered
ID: 21773754
Are you trying to set this up as a point to point or point to multipoint?
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 21780286
Point to point- 2 APs only.
0
 
LVL 10

Accepted Solution

by:
atlas_shuddered earned 1500 total points
ID: 21781723
Place the first bridge into root bridge (<--looks you have already done this) infrastructure only.  Remove workgroup bridge from second and place into non-root bridge, infrastructure only.  You said you have them under you desk, this is fine temporarily (though your future children may have "unique" genetic characteristics) but make sure they are both in the same polarity sphere (horizontal/vertical...essential that they are facing each other in mirror to one another).
0
 
LVL 28

Author Comment

by:mikebernhardt
ID: 21949347
I got our cisco rep to help out and now it's working. But basically it's what was suggested. for some reason there was some clutter that kept it from working right.,
0

Featured Post

Tech or Treat!

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to perform a hard reset on your router. Usually this is most-useful on wireless routers, but the same concept applies to nearly all home/SOHO routers. This process will return the router to factory defaults, so record your…
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question