Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Citrix Client Disconnects Right After Login - Presentation Server

Posted on 2008-06-12
2
Medium Priority
?
3,420 Views
Last Modified: 2012-06-27
I have one user that receives the following pop-up box immediately after logging into the Metaframe Presentation Server web interface for Citrix:

Closing the Citrix ICA client window will disconnect you from the Citrix Presentation Server. Are you sure you want to close and disconnect?

When they hit Cancel, they get this pop-up box next:

The remote session was disconnected because there are no Terminal Server License Servers available to provide a license. Please contact the server administrator

The server is Windows 2003 and the client is WinXP Pro.

I've read the other fixes by people deleting the following registry key:
HKEY_LOCL_MACHINE\Software\Microsoft\MSLicensing

From what I've seen, people report this as a fix when Windows 2000 Server is involved.  Does anyone have experience using this fix with Server 2003?  Or does the server not matter since the issue seems to be coming from the client machine?

I have confirmed that the user can login from another workstation, so I'm fairly certain it's a problem on the local workstation, and nothing on the server is directly related.  Just wondering if anyone can confirm using this fix with with a Win2k3 server and XP Pro client.
0
Comment
Question by:firststar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 8

Accepted Solution

by:
LKaushal earned 750 total points
ID: 21767266
Hi, It looks like your client has got 'temp' license, you can check it using TS Licensing console. This issue should resolve after deleting the regkey 'Lecensexxx' ket under "HKEY_LOCL_MACHINE\Software\Microsoft\MSLicensing" on CLIENT machine. Also, I have seen in some case you may also need to delete "ClientHWID" under "HKEY_LOCL_MACHINE\Software\Microsoft\MSLicensing\HardwareID".
On safer side, don't forget to take the backup of your registry.
0
 

Author Comment

by:firststar
ID: 21783864
Thanks for the response -

As a follow-up, before I tried removing the license key from the workstation, I changed the Citrix password, and logged in with the user credentials from my own workstation.  Initially I got the same message about disconnecting the ICA client.  I continued and click Log Off, and tried the connection again.

When I reconnected the session was normal, so I logged off and had the user try, and they were able to have a normal session.  Seems there was some sort of loop with their login on the server?

I appreciate you talking the time to respond.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After several days of searching and hunting for limited documentation, I wanted to share this guide to hopefully save someone the hassle of trying to figure this out on their own. I have tested this on Xendesktop 7.1 and PS 4.5 running simultaneous…
#Citrix #XenDesktop #POC #Proof-of-concept
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

671 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question