?
Solved

Symantec Enterprise Vault Installation on SBS 2003

Posted on 2008-06-12
7
Medium Priority
?
1,650 Views
Last Modified: 2008-07-31
Hi all - first post.

I've got users rapidly approaching 1GB Exchange mailbox sizes and trying to teach them email management practices is all too hard for them, so I've taken the plunge on advice given on other posts and purchased Symantec Enterprise Vault. I researched it pretty extensively and it seemed to be able to solve all our troubles automatically at the server level. After all the excitement with this product, I'm now in sheer frustration during install.

So it's on an SBS Server (which I found out after purchase is technically not supported although I've heard people getting it to work). For now, we're using MS SQL Server 2005 Express even with its limitations, however Symantec have advised me that Express Edition is supported.

Using the Enterprise Vault Configuration wizard I have set the Enterprise Vault Services account as Administrator. However I'm getting stuck on the SQL Server location screen. I installed SQL Express on the data partition (D:) at D:\Microsoft SQL Server\. I've tried entering the following into the SQL Server location field:
      D:\Microsoft SQL Server\MSSQL.1\MSSQL\Data

However I get the following error dialog:

"Failed to connect to SQL Server 'D:\Microsoft SQL Server\MSSQL.1\MSSQL\Data\'. Check that: - this SQL Server exists and is running - your Vault Service account has the correct privileges.

Any help is hugely appreciated.
0
Comment
Question by:swannpor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 12

Expert Comment

by:RWrigley
ID: 21770609
Are you sure you should be entering the physical database location, and not the server connection information (which would be <servername>:1433 by default, or \\<servername\pipe\sql\query if you're using named pipes)?
0
 
LVL 1

Author Comment

by:swannpor
ID: 21774192
Thanks for the suggestions RWigley. Tried both \\SERVER\pipe\sql\query and SERVER:1433 with the same results. How should I check that port 1433 is connected to SQL?
0
 
LVL 12

Expert Comment

by:RWrigley
ID: 21774978
By following the information in this article!  :)

http://msdn.microsoft.com/en-us/library/ms165718.aspx
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:swannpor
ID: 21775071
Well that certainly was part of the problem, I guess, but still getting the error. Went into SQL configuration and realised that both TCP and Named Pipes protocols were disabled. I enabled them and then restarted the SQL service but I'm still getting the same error with both \\SERVER\pipe\sql\query and SERVER:1433
0
 
LVL 1

Author Comment

by:swannpor
ID: 21777459
More to add. I've installed SQL Server Management Studio Express to ensure it's not an access permissions problem. I have added the relevant account (Windows authentication) into the Logins list with a dbcreator role. However, I still can't connect to the SQL Server.

Here's the error messages:

SQL Server Connectivity -> SERVER:1433: NamedPipes (NO), TCP/IP (NO)

SQL Server Permissions -> Test Failed for the following reason:[DBNETLIB][ConnectionOpen (ParseConnectParams()).]Invalid connection
0
 
LVL 1

Accepted Solution

by:
j0lx earned 2000 total points
ID: 21924307
When Enterprise Vault configuration asks for the SQL server *location*, it wants the *name* of the SQL Server, not the local path fo rthe database files. That got me the first time I installed it too!

If you want to use the default instance of SQL, then it's just the NETBIOS name of your SQL Server (eg: SERVER) in the example above. If you are using named instances (eg: SERVER\MYINSTANCE), then use the name of the instance SERVER\MYINSTANCE.

Once the connection is established, and you move to the next Wizard dialog box, Enterprise Vault will ask for the location of the databases and logs. At that point, you enter the local path of where you want EV files *on the SQL server* (eg: D:\MSSQL\SQL_DATA\EnterpriseVault\ and D:\MSSQL\SQL_LOGS\EnterpriseVault). Enterprise vault will then create the filenames according to its own naming conventions on the SQL server.

IMPORTANT:
- make sure the Vault Service Account has DB CREATOR privileges
- make sure the local paths on the SQL server exist and are allow full control effective rights for the Vault Service account
0
 
LVL 1

Author Comment

by:swannpor
ID: 22135442
Problem solved. Ended up loading MS SQL Server Management Studio Express, given that I am running this on SQL Express Edition. This let me get in and fix the permissions issue. Enterprise Vault now happily running and users now happily using declogged Outlook inboxes!

Thanks all for your help.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
We aren’t perfect, just like everyone else.  Check out the email errors our community caught and learn the top errors every email marketer should avoid.
The purpose of this video is to demonstrate how to set up a Mailchimp campaign. This will include styling and adding elements to a newsletter/email. This will be demonstrated using a Windows 8 PC. Mailchimp will be used. Log into your Mailchim…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question