0xC000006D Error running scheduled task

Trying to run a scheduled task but it continually fails.  Running filemon to see if there is anything not going through and receive
mtask.exe 796  open  UNC string to Application across network reulsts are the 0xC000006D Options: Open Access: execute

Has anyone seen this before

Moved server to new domain and all tasks failed after that.  Re created the tasks with new "Logon as Batch" username and credentials and task still fail.  

125 points refunded.
~sirbounty, zape
OSIadminAsked:
Who is Participating?
 
OSIadminConnect With a Mentor Author Commented:
Sorry about not leaving a better explained solution, was a busy day:

The workaround involved modifying the GPO to allow a specific Domain user to be the Local Admin of the server and also login as batch user. The username exists in both Domains and uses the same password and has the proper rights in both of the directories that it needs to work in.
The scheduled task now runs without an error.

Again sorry for the weak initial solution and thanks for your help
0
 
sirbountyCommented:
how's your task setup?
Anything in your \windows\SchedLgU.Txt file?
0
 
OSIadminAuthor Commented:
"DB-Prod-Grap.job" (DB-Prod-Graph.exe) 6/12/2008 9:11:28 AM ** ERROR **
      Unable to start task.
      The specific error is:
      0xc0000022: (Unable to find an error message)
      Try using the Task page Browse button to locate the application.

The Task is using a domain user that has Log on as Batch Job right from a group policy.  The task is calling an executable from a UNC path on another server.  

The task ran without issue on the other domain, when we switched the server from an nt4 domain to a 2003 domain, the tasks all failed.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
sirbountyCommented:
And you're running this on a 2k server, or 2k3?

Try scheduling it with the command-line tool:

schtasks /create /ru DOMAIN\USERNAME /rp PASSWORD /sc DAILY /st 09:00:00 /tn TEST /tr "\\SERVER\SHAREDFOLDER\FILENAME.EXE"
 
(Obviously changing the items in all-caps as appropriate)

Open in new window

0
 
OSIadminAuthor Commented:
Its running on a Win2k box
0
 
sirbountyCommented:
And did you try what I suggested?
0
 
OSIadminAuthor Commented:
not yet have not had a chance
0
 
OSIadminAuthor Commented:
Used a workaround to get the error to go away.
0
 
sirbountyCommented:
Can you elaborate on the workaround?
And can you respond if you ever even attempted my suggestion?
0
 
OSIadminAuthor Commented:
I tried your suggestion with the same results that i had before the scheduled task did not run.  
For the future though I found setting up the tasks per your suggestion to be much easier than the wizard.

Thanks for the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.