Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Web Application takes 60 seconds to load up, and need to display 1000s of records

Posted on 2008-06-12
2
Medium Priority
?
210 Views
Last Modified: 2013-11-26
Hi Experts,

I have an aspx page with two html tables on it and various other asp.net and ajax toolkit controls.

My first problem with this page is the load up, as it takes 60 seconds of staring into white space before it loads. I can fine tune my stored proc queries (add indexes, whatever) and I can remove some controls I could do without, but it's not making it much quicker. I've looked at recommendations to load the controls AFTER loading the html, but that seems dicey and I'm no pro-coder.

It seems to me there is so much over-head with ASP.NET that outweighs the benefit of using asp.net..

I used to use gridviews, not I'm looping through the dataset and building dynamic html table, just so I can have quick, javascript sorting, filtering, and paging on the client..but this only works well with <100 rows. Anything more, and my memory gets eaten up.

The second problem is that one of the tables needs to display 3000 records. And I need to be able to filter, sort, and page quickly.

It seems to me that if I can remove the loading up of these asp.net controls, then I could just go back to using a streamlined html page with javascript. But then the table with the large dataset is still a problem.

So could you guys give me some advice on the way forward here? I'm totally stuck. :(

Thanks,
rss2
0
Comment
Question by:rss2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 19

Accepted Solution

by:
elimesika earned 2000 total points
ID: 21772773

HII

How many seconds the SP is running when you are executing it directly against the sql server ?
0
 

Author Closing Comment

by:rss2
ID: 31469105
That was the problem. But at least those sps aren't mine. :) Thank you!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick way to get a menu to work on our website, is using the Menu control and assign it to a web.sitemap using SiteMapDataSource. Example of web.sitemap file: (CODE) Sample code to add to the page menu: (CODE) Running the application, we wi…
The article shows the basic steps of integrating an HTML theme template into an ASP.NET MVC project
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

664 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question