Solved

How do I allow Multiple RDP Sessions?

Posted on 2008-06-12
11
33,873 Views
Last Modified: 2012-06-27
When we are logged on to the 2008 Server and remote session is started the server session is logged off and the same goes if 2 of us are using RDP.  In windows server 2003 we could have the server logged on and have multiple sessions of RDP without kicking each other off.   I have played with the Group Policy for Terminal Services but have had no luck.
0
Comment
Question by:ocontoco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 1

Expert Comment

by:adamroman
ID: 21771026
go to start>programs>administrative tools>terminal services>terminal services configuration

Under general settings change "restrict each user to a single session" to NO
0
 
LVL 58

Accepted Solution

by:
tigermatt earned 125 total points
ID: 21771542
You have several locations where you may need to change a setting in order to allow multiple remote desktop sessions.

The most likely location will be in Group Policy - I suggest you run rsop.msc on the server, then browse to the following container and check whether the policy is applied (or not). After running rsop.msc from the "Search" box on the start menu, go to Computer Configuration, Administrative Templates, Windows Components, Terminal Services and check whether the "Restrict Terminal Services users to a single remote session" setting is Enabled. If it is, note down the policy in which it is enabled, then open that Group Policy and remove the policy.

Alternatively, the other location in which this may be configured is the Terminal Services Manager. This isn't the location I would suspect this is configured - and isn't really the best location for setting it - but to check and possibly remove it, do the following:

Open Terminal Services Configuration. In the console tree, click Server Settings. In the details pane, right-click Restrict each user to one session, and then click Properties. Uncheck the Restrict each user to one session check box, and then click OK.

There's a guide on Technet at http://technet2.microsoft.com/windowsserver/en/library/da5367e2-b506-48e9-8533-f38c28ceb6611033.mspx?mfr=true.

Please remember that the user sessions functionality and Terminal Services is completely revamped in Windows Server 2008. The /console switch which could be used with previous versions of Windows to access the console through RDP will now no longer work, since session 0 is now no longer accessible and interactive for users to actually use (it is just for services to login as). To replace the /console switch is the /admin switch - running mstsc /admin will connect you to the physical console of the server, and when running Terminal Services in Administration Mode (the default, if you have not purchased Terminal Services licenses), you are limited to a maximum of 2 sessions INCLUDING the console. http://blogs.msdn.com/nickmac/archive/2007/11/28/mstsc-console-switch-in-windows-server-2008-and-windows-vista-sp1.aspx

-tigermatt
0
 
LVL 51

Expert Comment

by:Netman66
ID: 21771647
There is a Group Policy element that is not defined by default that may be of some use for you.

In the Default Domain Controller Policy:

Computer Config>Admin Templates>Windows Components>Terminal Services>Connections :: Deny logoff of an Administrator logged into the console session.

Enable this policy element.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ocontoco
ID: 21772557
tigermatt - Got a question for you are you saying that if we didnt purchase a TS Licensing that we can only have 2 sessions including the console?  Which means only one rdp session is allowed - correct?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 21772630
Yes, only 2 connections are allow for RDP in Admin mode.

In Application mode, you pay per TS CAL.

0
 

Author Comment

by:ocontoco
ID: 21772885
I've used the Group Policies for Terminal Services is there way to restrict RDP session from being able to disconnect the console session?  I have enabled the Deny logoff of Administrator but its not working correctly because it still gives the rdp session user the ability to force the log off.
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 21772906
Run an rsop.msc from the Search box on the Start Menu, examine the output and ensure the policy is actually being applied.

AS for the licensing - you can only have a maximum of 2 user logins (including the console) if you use Terminal Services in Remote Administration mode. As I said above this differs from Server 2003, where you could have 3 logins - console and two RDP.

-tigermatt
0
 

Author Comment

by:ocontoco
ID: 21772925
I have done this already and it is set.  Could this be because the consule and the rdp session are using the adminstrator login?
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 21772934
Ah, that is probably why. If you try another user then I doubt it will happen.
0
 

Author Comment

by:ocontoco
ID: 21772968
I  just test this and this is not true I use my actual user which is a domain admin and it still let me disconnect the adminstrators session.
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 21773180
I think it's because you have Administrator rights over the server (since you're a Domain Admin) you are still able to force the user to log off. The GPO isn't going to apply to an Administrator because they have elevated rights to just log off another logged in user using another method if necessary.

From what I can see that GPO is only actually going to apply to non-Administrator user accounts.
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
NTP time source for DC 3 91
Restore a DC asap 11 66
Modifying Robocopy script to migrate (move) from one drive to NFS share (retryable) ? 21 100
BgInfo help 5 108
Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
If you migrate a Terminal Server licenses server inside the 2008 server family, you can takte advantage of the build-in migration tool. If you like to migrate an older 2003 Server (and the installed client CALs) to a 2008 R2 server for example, you …
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question