Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

IPDS ethernet ibm 4247: editor not starting

Posted on 2008-06-12
24
Medium Priority
?
756 Views
Last Modified: 2013-12-06
hi,
i bought 3 ibm 4247 eth ipds printer. For one all it working fine. For the 2 others I have issue to make them works.

I create the printer in the iseries. the outq is fine, I can start the printer and the queue but whan i tried to launch the edit strprtxtr Pinter_name nothing append, the normal msg appear: "Lecteur ou éditeur 266828/QSPLJOB/PG soumis à QSPL de QGPL." but the state of thi outq is RLS and not RLS/WTR

Thks for your help.

Here is the config of the printer:
DEVD        PG    
OPTION      *BASIC
            *PRT  
                   
DEVCLS      *LAN  
TYPE        *IPDS  
MODEL       0      
LANATTACH   *IP    
AFP         *YES  
PORT        5001  
ONLINE      *YES  
FONT              
            011    
            *NONE  
FORMFEED    *CONT  
SEPDRAWER   *FILE  
SEPPGM      *NONE  PRTERRMSG   *INQ    
MSGQ        *CTLD  
            QSYSOPR
              QSYS  
ACTTMR      170    
IMGCFG      *NONE  
MAXPNDRQS   6      
PRTCVT      *YES    
PRTRQSTMR   *NOMAX  
FORMDF      F1C10110
              *LIBL
CHRID       *SYSVAL
RMTLOCNAME              
            192.168.1.69
                         
                         
                         
USRDFNOBJ   *NONE        
              *NONE      
USRDTATFM   *NONE        
USRDRVPGM   *NONE        
DEPLOCNAME  *NONE        
                     
             *NONE    
                     
                     
             *NO      
 PUBLISHINF          
             *UNKNOWN
             *UNKNOWN
             *UNKNOWN
             *UNKNOWN
             *BLANK  
                     
             *UNKNOWN
TEXT        *BLANK

0
Comment
Question by:lviollet
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 9
24 Comments
 

Author Comment

by:lviollet
ID: 21791336
If you need more info, tell me i will give you all you need!
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21792985
Hi lviollet,

Did you try to configurate them with Auto config?
 to do that, delete the non working printer definitions and type :
CHGSYSVAL QAUTOCFG(1)
switch you Printers on, and thay will be recognized.
if you like you can switch it off again by

CHGSYSVAL QAUTOCFG(0)

You can check the current value by typing : DSPSYSVAL QAUTOCFG

Regars,
Murph
0
 

Author Comment

by:lviollet
ID: 21806330
hi,

i tried but i have the following error msg when i tried to change the value to 1 (current value = 0)
Paramètre VALUE incorrect pour valeur système QAUTOCFG.
   => UK: value parameter incorrect for the value system QAUTOCFG

I tried the help of F4 but same thing (the command generated was this one: CHGSYSVAL SYSVAL(QAUTOCFG) VALUE(1) )

Have you any ide?

BR
Laurent
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:lviollet
ID: 21806389
i find for the command I ned to insert '
CHGSYSVAL SYSVAL(QAUTOCFG) VALUE('1')
0
 

Author Comment

by:lviollet
ID: 21806498
How can I find which is the device created? I have a long list wthe several device already created by autoconfig...
Thks
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21807537
Hi lviollet,

Isn't there a date that shows when it was created?
If not, look in the objectdescription
I'm not in the office so from my head :
Type:  WRKOBJ *ALL/*ALL *DEVD
You will get a list of all Device descriptions

For a generic list type: WRKOBJ *ALL/PRT* *DEVD
for all devices starting with PRT.

Regards,
Murph

0
 

Author Comment

by:lviollet
ID: 21811809
Hi, No device has been created...
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21813289
Hi lviollet,

Is there an outq created? Type:  WRKOBJ *ALL/*ALL *OUTQ
(a Device description is not required, if you use the printer with a remote outq)
0
 

Author Comment

by:lviollet
ID: 21814754
neither outq. Just for information I succeed to print on the printer directly from a computer (I did not used IPDS for that, i used the port 9100).
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21814972
Just to be sure,
Is this printer connected to the network with a Networkcard, a printerbox or a printer-session in CA ??
0
 

Author Comment

by:lviollet
ID: 21819809
Hi, the printer had a ethernet card directly connected to our LAN. This card had IPDS option.
BR
Laurent
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21820002
Thanks,

So 1 out of 3 is working fine?
did you check the configuration inside the printer especially:
-the LAN Config (Default gateway etc)
-Firmware version of the LAN Card
-Firmware version of the printers

Regards,
0
 

Author Comment

by:lviollet
ID: 21902419
Hi,GW is the same
FW LAN is the same also: 3.08
Base code is the same : 7.07

I tried to replace the printer which was working by one which not and it works fine! I only change in the printer the IP adresse.
So it should come from the setup on the AS400 but which one?

(sorry for the delay but I did a small break)

Regards, Laurent
0
 

Author Comment

by:lviollet
ID: 21902551
oups, I forget I tried also to configure the printer as non ipds, and it failed.
i forget to tell you that the setyp which is working run on a different AS400. (I have 2 of them).
Hey I tried to setup a second printer on the other AS400 and it works fine!!! So it s coming from the AS400 side but I do not know what. The only difference I saw is the the one where the printers does not work has the liscence for IPDS...


If you have an idea? BR, Laurent
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21902566
Just delete the definition and create it again
or try to copy the working one with crtdupobj


0
 

Author Comment

by:lviollet
ID: 21902639
hi, how do i user crtdupobj between 2 as400?
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21903880
Oww that's the first time I understood that it's about 2 AS/400's  or did I miss something?

Just do a save object to tape or savefile or whatever and restore it on the other 400.

Is the OS on both systems the same version?
Does both AS/400 are using a French OS?
If not check the CCSID ( or Code page)

Good luck,
Murph
0
 

Author Comment

by:lviollet
ID: 21906125
Sorry I miss the point in my explaination and I thought befre that it was coming from the priner and not from the AS400...

Both as the sames OS V5R3 in french for both system. I did not succeed to restore the object saved.
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21906453
what was the problem during restore?
Normally it should be possible.
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 21906479
Hi Iviollet,

Please can you check if the devd you think you are using  (QSPL) is the onlyone with this name?

WRKOBJ *ALL/PG  (if PG is the device description)

(Be sure you have the right authority to see all objects)
If you are not sure if you see all objects, try an other name for the device e.g. PG001
just to be sure you use the right devd.

Regards,
Murph

0
 

Author Comment

by:lviollet
ID: 21906503
Hi, yes it is the only one.

 Opt  Objet       Type      Biblio      Attribut    Texte                      
      PG          *FILE     £LIBRARY    PRTF                                  
      PG          *DEVD     QSYS        PRTLAN                                
      PG          *OUTQ     QUSRSYS                 File attente en sortie pour

I also tried to create with an other name (PU for instance) but it does not work.
0
 
LVL 27

Expert Comment

by:tliotta
ID: 21930101
Laurent:

Rather than trying to save/restore a device description object, try using the RTVCFGSRC command. Retrieve the configuration source statements into a source member. Transfer the source member to the other system and execute it.

You might see errors when the system tries to create the device. Correct parameters as needed. Or you might see errors when trying to get the device to an active state. Or any number of useful messages might become available.

Tom
0
 

Author Comment

by:lviollet
ID: 21957981
Hi,
i find out what going on, I have an issue with the key code that IBM send to me for using PSF400 which give me strange behaviour with the printer.

thanks to all that past time to help me on that matter!

BR

Laurent V.
0
 

Accepted Solution

by:
lviollet earned 0 total points
ID: 21958026
Hi,
I find out what s going on. It was the PSF400 module o, the AS400 which make strange behaviour with the printers.

Thks to all  of you that help me on that matter.

BR

Laurent Viollet
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to solve seemingly unsolvable printer issues. Users sometimes run into printing issues where all the normal steps do not seem to work. Well the steps below can show users how to take one extra step beyond the normal steps needed to remove old…
When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question