Solved

Certificate configuration

Posted on 2008-06-12
7
319 Views
Last Modified: 2009-12-16
After many hours of frustration, i've reached my endpoint...
What is the proper procedure for configuring and deploying turbo-SSL cert from GoDaddy, including intermediate cert, on SBS2003 R2 premium?  Currently, I have IIS cert as publishing.localdomain.lan and the ISA cert is supposedly from GoDaddy as server.domain.net, which is also our FQDN.  However, when I view the cert in ISA, it appears to be self-signed, and I get intermittent cert warnings when logging in from the internet outside the domain.  RWW, OWA, OMA, and VPN all are functioning properly.  I'm using a 3rd party SSL cert for the purpose of active-sync on multiple smartphones via exchange direct push.  Ironically, active-sync is the only feature I cannot get to deploy appropriately.  Please help with any questions or comments.
0
Comment
Question by:sborbust
7 Comments
 
LVL 19

Expert Comment

by:Stephen Manderson
ID: 21776256
Hi there,

You can apply the certificate via the CEICW and attach the cert file in the wizard this should take care of the changes in IIS and also ISA for you providing you have also selected the options for OWA

For additional reference see the below wizard walkthrough
http://www.sbs-rocks.com/sbs2k3/sbs2k3-n2.htm

Also what certificate is shown when you try to login from the internal network?

Regards
Steve
0
 
LVL 6

Expert Comment

by:Nyah247
ID: 21779415
Have you tried Godaddy support.  I have Digicert and they have some nice tutorials and I would hope Godaddy would as well.  

This does not mean it is possible...but it does look like another has had a similar issue:

http://forums.isaserver.org/m_2002065633/mpage_1/key_/tm.htm#2002067135

0
 

Author Comment

by:sborbust
ID: 21781088
Thank you to both of you.  I reviewed both links and found that I have applied the techniques already.  However, for some reason unknown to me, my cert is now showing as  GoDaddy Class 2 cert from both inside and outside doman, but, I stil cant get active-sync to function properly.  When i sync with SSL required on the phone, i get error code 85010014.  When I uncheck require SSL, i get error code 85030022; 'the server you are sync'n with is not an Exchange server'.  I thought the certificate was the issue with active sync, but i believe we resolved that already.  HELP!
0
 
LVL 19

Expert Comment

by:Stephen Manderson
ID: 21781413
It can be an issue with the order you install the root cert before the int cert, I had to resolve this exact same issue a few months back. I removed all the certs and started again. worked like a charm. Also be sure to use the CEICW on SBS or you will have yo configure ISA manually with can be a troublesome if you havnt done it before

0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 22825515
I realize that this question is a bit old, but thought I'd provide the answer anyhow:
http://sbsurl.com/ssl 

Jeff
TechSoEasy
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So the following errors occurs in 2 ways that I am aware of at this stage, and you receive one of the following error messages: ERROR 1. When trying to save a rule: No Web listener is specified for the Web publishing rule Autodiscovery Publishin…
There are several problems reported according slow link speeds or poor performance in TMG 2010, UAG 2010 or ISA 2006. I want to collect here some of the common issues together to give a brief overview what can be the reason. Nevertheless, not all of…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now