Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2007 AutoDiscover

Posted on 2008-06-12
13
Medium Priority
?
953 Views
Last Modified: 2012-05-05
HI

I have set up an exchange server with the following.

Windows Server 2008 Enteprise on a 2003 Server Domain with 2 domain controllers.
Exchange seemed to be working fine until i reinstalled network card drivers to make use of jumbo frames on one nic, and ever since i have been getting asked for a password in outlook 2007. test-outlookwebservices failed with error 1013 and 1006. Outlook anywhere is enabled and i have a valid godaddy ucc certificate for autodiscover.mydomain.com and webmail.mydomain.com.

My internal dns server points clients to webmail.mydomain.com for everything and when testing autodiscover in outlook 2007 everything looks fine. I wned to test get-webservicesvirtualdirectory | fl name,internalurl,externalurl and i get an access is denied error. I am thinking it is something to do with authentication on iis7 to the 2003 domain controllers.

Can anyone offer any advice?
0
Comment
Question by:dogsnaps
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
13 Comments
 

Author Comment

by:dogsnaps
ID: 21774674
hi all i have managed to fix the test get-webservices error if i was to open ems as administrator. However i still get the error 1013 when testing outlook web services.
0
 
LVL 16

Expert Comment

by:LegendZM
ID: 21776049
0
 

Author Comment

by:dogsnaps
ID: 21776104
hi

i have tried that, and added the registry edit, set the binary to 0xff and still have the error. thanks for the suggestions though.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 16

Expert Comment

by:LegendZM
ID: 21776123
0
 

Author Comment

by:dogsnaps
ID: 21776185
hi, i have tried that an still get an error going to https://localhost/autodiscover/autodiscover.xml. when going to local host i get a certificate error but i dont with my fqdn, meaning my certificate is properly loaded. the output is errorcode 600 invalid request.

i am assuming this is not correct? From this i figured that it is more than a loobback issue.
0
 
LVL 16

Expert Comment

by:LegendZM
ID: 21776202
I believe the 600 error code is normal when accessing the autodiscover address internally, What happens if you try to use a real outlook 2007 client?
0
 

Author Comment

by:dogsnaps
ID: 21776209
outlook 2007 works fine when on the domain and i originally had a heap of password issues with connecting over  https (outlook anywhere) but seem to have resolved those, yet i still cannot test-outlookwebservices.
0
 
LVL 16

Expert Comment

by:LegendZM
ID: 21776217
What are your authentication settings on IIS7?
0
 

Author Comment

by:dogsnaps
ID: 21776224
on the default website they are this:
anonymous and windows
on the autodiscover they are:
basic and windows
on the iis server
anonymous and windows.
should i add basic here or not?
0
 
LVL 16

Expert Comment

by:LegendZM
ID: 21776248
Try adding basic to default website, also try removing windows,
Try adding anonymous for auto discover
try adding basic to iis server
0
 
LVL 16

Accepted Solution

by:
LegendZM earned 2000 total points
ID: 21776305
If that doesn't work, try removing / re-adding the CAS role, would probably fix it up
0
 

Author Closing Comment

by:dogsnaps
ID: 31466778
Thanks for that it worked a treat!
0
 

Expert Comment

by:FrenchWalker
ID: 26207286
I Solved it. You can try disabling ASP.NET Impersonation, Disable Anonymous, Digest and Forms. Enable Windows and Basic ONLY for autodiscover and EWS.

After numerous forums, pulling hair out this definately resolved for us.

We have a Communications CERT, set the internal to local domain ie domain.local, external to public domain ie domain.com.au and all works well.

Good luck.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question