• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3136
  • Last Modified:

Security Certificate on the server is not valid. Error 0x80072F0D

My client recently purchased a E650 Orange Smartphone from the UK.  When connecting to our Exchange 2003 server I receive the error 'security certificate on the server is not valid' error 0x80072F0D.  The certificate installed on Exchange server is from Equifax Secure Global, who is owned by GeoTrust.  I downloaded the only root certificates I could find and those were at GeoTrust.  I installed them but to no avail.  When I go to https://webmail.mydomain.com/oma I received the prompt 'The name, date, or issuing authority for the site's security certificate is not valid'  All suggestions would be appreciated.
0
INetX
Asked:
INetX
  • 3
  • 2
1 Solution
 
Stacy SpearPresident/Principal ConsultantCommented:
The site name on the certificate must match the actual address.

So since you have webmail.mydomain.com, your certificate must be webmail.mydomain.com.

I am willing to bet you just have mydomain.com on the certificate.
0
 
INetXAuthor Commented:
OH...If only it was that simple.  Thanks for the suggestion but the certificate is for webmail.mydomain.com.  It was purchased from Equifax and when I go to the details of the certificate and expand it shows the certificate for my domain, webmail.mydomain.com.
0
 
Stacy SpearPresident/Principal ConsultantCommented:
argh!! :)

Is the error via the device or does it appear on desktop systems as well?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
INetXAuthor Commented:
Thanks for the reply, I am receiving the error:0x80072F0D on the device.
0
 
INetXAuthor Commented:
I found the solution!!!.  I

f anyone else has this same problem with obtaining a root cert for Equifax here is the link:
http://www.geotrust.com/resources/root_certificates/index.asp 

You want to download this cert "Root 5 - Equifax Secure Global eBusiness CA-1 (Base-64 encoded X.509)" save it to your desktop then transfer it to the phone.  From the phone click on the cert and it will give you the option to install.  This should resolve your certificate problem.  You can verify that by going to Internet Explorer on your phone and entering the url to your OWA, i.e. https://webmail.domain.com/owa.  If it goes directly to a login and does not generate any SSL cert errors then the certificate issue has been resolved and for me it was on to the next issue, which I found the answer to here http://www.amset.info/exchange/mobile-85010014.asp
0
 
advserverCommented:
Thanks, Root 5 - Equifax Secure Global eBusiness CA-1 (Base-64 encoded X.509) worked for me. :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now