Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 266
  • Last Modified:

Set Desktop Background when logged off

I have set the users desktop through group policy, but this only works when logged in.   When I log off, the desktop still shows my preferred desktop, though if the logon dialogue box is moved it's like a paint brush which rubs out my desktop, and leaves a plain blue desktop.

After reboot, the plain blue desktop is shown again until someone logs in when my desktop is shown again.

I'm looking for a desktop (my one!) that is shown on boot, and not 'removeable' when logged off..
0
ivan_sanders
Asked:
ivan_sanders
  • 6
  • 6
1 Solution
 
WakeupCommented:
Might need to log on to the machine locally?  and not the domain to set the "Local Machine's" desktop?

0
 
Jay_Jay70Commented:
are you using the active desktop policies in GPO?

I know these can be flakey - i had to use a ref hack to get rid of the dell splash screens
0
 
ivan_sandersAuthor Commented:
Yes, Active Desktop Policies..
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Jay_Jay70Commented:
active desktop policies are applied at a user level - there is a regkey for wallpaper which controls the splash screen initially, may be worth controlling that via GPO
0
 
ivan_sandersAuthor Commented:
Any ideas which one? - I've searched, but it's not obvious to me...
0
 
Jay_Jay70Commented:
HKEY_Users\.default\Control Panel\Desktop\Wallpaper

0
 
ivan_sandersAuthor Commented:
ok - that's through the registry - I figured when you said GPO you meant through Group Policy???
0
 
Jay_Jay70Commented:
i do, if you change that setting on a machine, does it fix your problem? if it does then we can create a template to apply through GPO
0
 
ivan_sandersAuthor Commented:
I've set that registry with the file location (ie, c:\windows\filename.jpg) - no good....

I see above in the same hive that there is a setting for the screensaver such as c:windowsscreensave.exe (ie, no backslashes at all....)

I've tried both, and also opened the jpg in a browser and done the 'right click, use as desktop'

Still no good...
0
 
Jay_Jay70Commented:
hmm active desktop policies are a minger - i hate them as they are no end of trouble
0
 
ivan_sandersAuthor Commented:
Getting there Jay Jay - I figured out that it HAS to be a bmp...     The Active Desktop that we use is a jpg, but if you set HKEY_Users\.default\Control Panel\Desktop\Wallpaper it has to be the bmp.

I've now got the functionality I'm looking for - just want to set it via GPO if you could help with that one!

Cheers

Ivan
0
 
Jay_Jay70Commented:
excellent!

now you want to follow the ms guide to role this change out :)
http://support.microsoft.com/kb/225087
0
 
ivan_sandersAuthor Commented:
Great work - thanks
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now