Solved

Adding router to cable broadband

Posted on 2008-06-13
5
2,165 Views
Last Modified: 2012-06-21
I have a client with Virgin Media cable broadband.  He has a Motorola SB5100 cable modem with both USB and network connectivity.  In its original configuration the modem is plugged directly into a desktop PC using a standard network cable.  IPCONFIG shows the network card IP address as 77.xxx.xxx.xxx (Class C) and a Gateway address of 77.xxx.xx.xxx.  Everything works and speed is good.

We now want to add a router to this set-up  this router will provide two main additional features  a VPN to the clients office (some 20 miles away) and wireless connectivity.  Neither of these issues is seen as a problem once the router is installed and internet connectivity is working.

The issue is however that Internet connectivity cannot be achieved.

The router is a Draytek Vigor 2820n (802.11n wireless).  See http://www.draytek.co.uk/products/vigor2820.html  The 2820 series routers have dual (fail-over) WAN ports.  WAN 1 is for standard ADSL via a standard cable to micro-filter and BT socket.  WAN 2 is for an Ethernet connection to a second ADSL modem, cable modem or any other Ethernet-based Internet feed.  Further the literature states If you don't have ADSL, the Ethernet WAN port can instead be used as your primary/only Internet connection (using NAT) so the same router can be used for either ADSL or Ethernet Internet connections.

So I am confident that this piece of kit will work if I can find out how.

As DHCP to the PC and a wireless connected notebook is required from the 2820n I accessed the cable router webmin (on 192.168.100.1) and disabled the DHCP service.

I used a standard  (not X-over) network cable from the cable modem to the router WAN 2 socket and another standard network cable from one of the 4 x Ethernet ports on the 2820n to the PC network card.

I read-up web-based advice on connecting routers to cable systems and started from everything switched off and unplugged from power for a couple of minutes.  Then I brought the cable modem up and waited for the service to connect.  Then I switched on the 2820n.

The 2820n was set-up with the users Virgin Media username and password and the broadband domain (I used blueyonder.co.uk as this seems to be valid as the user has a blueyonder.co.uk email address)

The 2820n webmin showed no connectivity on WAN 2 (WAN 1 is disabled).  

I had by this time also spoken to Virgin Media support.  Very basic help is given but nothing in depth as they do not support third-party routers  a fact repeated to me several times!  They want to sell their routers at £40 a time but they have no VPN engines and are only 54G.  I did glean that the DNS server addresses were important.

So I tried putting in the DNS server addresses into the 2820n  no change.

Then I read some more web-based articles and saw notes concerning the MAC address.  This basically advised to try fooling the broadband service into believing it was connected to a network card rather than a router (tenuous I thought but work a try).  So I entered a manual MAC address for the network card into the router and Bingo!! The 2820n showed a connected WAN 2 port.

Trouble is that the browser wont browse it just shows Page cannot & and IPCONFIG shows Destination Host unreachable on pings to website names and IP addresses.

HELP!  I need very specific advise on what settings a put into the router.  I have the same router on my network so I provide below screen-shots of the relevant areas (I have ADSL  so some of the settings are not pertinent to the cable broadband I am trying to work with at my clients).

Screen-shots attached

1st shows how I have set-up the router for the cable broadban
 
2nd shows the WAN 2 config page 1 (PPPoE tab).  I had enabled this page and set the network card MAC address  all other settings remain the same.

3rd shows the WAN 2 config page 2 (Static or Dynamic IP tab). This was Enabled and I set it to Obtain  an IP address automatically.  Router name Vigor 2820n (I hoped this was just a label.  Domain name blueyonder.co.uk  I again specified the network card MAC address.  All other setting left alone.

4th shows  the WAN 2 config page 3 (PPTP tab).  Left disabled and with no settings changed.
 
5th shows how the router is set-up for the cable service  i.e. Channel 1 disabled and Channel 2 enabled (reverse of the settings on my router)

EE-screen-shots.doc
0
Comment
Question by:MikeDTE
  • 2
  • 2
5 Comments
 
LVL 17

Assisted Solution

by:ExcelGuide
ExcelGuide earned 20 total points
ID: 21777279
is there an option you can set the router to access point? I had these problems as well but they were solved as I turned the option "access point" on. Wireless and VPN are working now! But I have the Asus WL series (around 150 - 200 dollars)...
0
 
LVL 16

Assisted Solution

by:btassure
btassure earned 20 total points
ID: 21783404
You will need DNS servers in there at some point. Recommended setup is to put the Virgin Media DNS servers in on the static/dynamic IP page. You also said you turned off DHCP on the LAN. Why? Are you manually specifying addresses internally? Again, recommended practice here would be to enable DHCP (make sure it is using a DIFFERENT range to that of your other office or your VPN will have problems). This is done on the LAN settings page - if you do change the range make sure you change the ip address of the router to be in the same range as well or you won't be able to see it.
0
 

Author Comment

by:MikeDTE
ID: 21788064
Thanks Psycotec for your comment - I cannot locate amn option to set the router as an access point.
0
 

Accepted Solution

by:
MikeDTE earned 0 total points
ID: 21788092
Thanks btassure - I did enter the Virgin Media DNS servers - "I did glean that the DNS server addresses were important.  So I tried putting in the DNS server addresses into the 2820n - no change." this iss stated in my question.

I turned off DHCP in the Cable Router as the local IP address (192.168.5.1) was being served by the 2820n DHCP server which is ON.  "As DHCP to the PC and a wireless connected notebook is required from the 2820n I accessed the cable router webmin (on 192.168.100.1) and disabled the DHCP service. " this is stated in my question.

The office subnet is different it's on 0 (192.168.0.x).  

I have set-up dozens of VPNs with ADSL both ends but I have never had to use Cable Broadband before and that's where tthe issue is for me.
0
 
LVL 16

Expert Comment

by:btassure
ID: 21789865
You have the cable modem plugged into a cable router and then into the 2820n?

Virgin-----Cable modem----cable router----2820n----PC
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now