?
Solved

Can not access intranet site with IP address or hostname. Local host works fine (Apache)

Posted on 2008-06-13
4
Medium Priority
?
1,275 Views
Last Modified: 2012-06-22
I have installed WAMP on Windows 2003. Every thing seems to be working fine except for one thing. I can access my website with the url http://localhost/Mysite and http://127.0.0.1/mysite

When I try to use the IP (http://198.162.1.55/mysite or hostname (http://hostname/mysite) I get an error that says:

You are not authorized to view this page
You might not have permission to view this directory or page using the credentials you supplied.

I can also not access the website from any other computers on my domain but I guess that is related to the same problem that I can not use the IP or hostname.

Is there configuration that needs to be done to Apache so that I can use the Ip and host name or is this a network configuration issue? I have disabled my firewall but I have the same problem.

Thank you
0
Comment
Question by:R2-D2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 57

Accepted Solution

by:
giltjr earned 1200 total points
ID: 21783693
Did you setup any virtual hosts?  Do you have any deny/allow statements?
0
 
LVL 43

Assisted Solution

by:ravenpl
ravenpl earned 800 total points
ID: 21784294
Definitely there must be following statement somewhere in the httpd.conf of .htaccess
Allow from localhost
Deny from all
0
 

Author Comment

by:R2-D2
ID: 21791596
I did not set up any virtual hosts. I have tried setting up my virtual host like this but it did not work:

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
   DocumentRoot "C:\wamp\www\mysite"
   ServerName servername.local
</VirtualHost>

I have also tried:

NameVirtualHost 192.168.1.5

<VirtualHost 192.168.1.5>
   DocumentRoot "C:\wamp\www\mysite"
   ServerName servername.local
</VirtualHost>

My httpd.conf is as follow:

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

I still get the message:

 Forbidden
You don't have permission to access / on this server.

Can you see anything that I have not configured correctly?

0
 

Author Comment

by:R2-D2
ID: 21791837
I have found the problem. It was like you suggested. I found the problem in the Apache deny/allow statements.

Thanks for your help!
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: kevp75
Hey folks, 'bout time for me to come around with a little tip. Thanks to IIS 7.5 Extensions and Microsoft (well... really Windows 8, and IIS 8 I guess...), we can now prime our Application Pools, when IIS starts. Now, though it would be nice t…
Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
Suggested Courses
Course of the Month12 days, 11 hours left to enroll

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question