?
Solved

Need to Login To Citrix Twice

Posted on 2008-06-13
13
Medium Priority
?
3,022 Views
Last Modified: 2010-04-21
Hi there
I have 2 citrix presentation servers on my domain
i am using published desktop with apps being delivered through pnagent
all works well however if the user launches the published desktop on citrix1 and then opens an application on the second server they are being prompted to log in again and they have to re enter their username and password information

Thanks
0
Comment
Question by:dougdog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 2
  • 2
  • +1
13 Comments
 
LVL 19

Expert Comment

by:Zaheer Iqbal
ID: 21777782
Make sure the Cleint is set to passthrough authentication rather tahn prompt.
0
 

Author Comment

by:dougdog
ID: 21778142
hi there
pass through is set
when i log onto the published desktop with my user account pass through works for pnagent to load apps on the same server it is only when i access an app on a different server
0
 
LVL 8

Accepted Solution

by:
LKaushal earned 1000 total points
ID: 21778458
Try this --. on your Passthorugh server (Published Desktop server), import  icaclient.adm file (\Program files\Citrix\ICA client\configuration ) to your GPO.
1. In the Group Policy Object Editor, right-click Administrative Templates and click Add/Remove Templates.
2. Browse to C:\Program Files\Citrix\ICA Client\Configuration and add the icaclient.adm file.
3. Under Computer Configuration > Administrative Templates > Citrix Components > Presentation Server Client > User Authentication --> select 'Local User name and password' --> Right-click and enable the policy for pass-through authentication. This policy is applied to all users logging on to this server.
4. Save Gorup policy and then test.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:dougdog
ID: 21779981
hi there,
i have a bit more info which may help
i dont think it is pass through issue as this is what is happening
i have a published desktop which is published to both servers
if a user happens to open the published desktop on citrix1 then they have no problems accessing apps on citrix1 and citrix2 with no additional login required.
However if they open the published desktop on citrix2 they are being prompted for windows login details ie loging into the server again before they can run app.
Apps on the same server run fine
0
 
LVL 14

Assisted Solution

by:Craig Roberds
Craig Roberds earned 1000 total points
ID: 21780310
What I have found works for this is to go to the WI, Open up your PNAgent site, highlight the config.xml, go to configure authentication methods, and go to properties and check the box that allows user to save their password.  Then the first time it prompts them they can use the check box to save their password and it will work after that.

I had an issue like this and for some reason even though you did pass through it would not work when it switched servers but the save password feature did work.
0
 

Author Comment

by:dougdog
ID: 21780407
i dont have that option im using ps4.5 their is no password option
i dont understand how if im logged onto citrix 1 everything is fine which means pass through is working
it is only if im logged onto the second server
0
 
LVL 14

Expert Comment

by:Craig Roberds
ID: 21780528
I have 4.5 also.  In you Access Management Console, Open up Citrix Resources-->Configuration Tools-->Web Interface and then open up your PNA website, and under that should be a config.xml.  Highlight it and in the right pane click on 'Configure Authentication Methods'

You can click the Pass Through here but I know I have had issues before when you login to a published desktop and then populate the desktop with PNA it doesn't pull the login info.  There is probably a way to script it but instead what I did is Click on the Properties button in this new window and then go to 'Prompt-->Password Settings and click the checkbox that allows the user to save the password.  They have to enter it the first time anc click the checkbox in the PNA login screen, but after that it works like a charm.
0
 
LVL 8

Expert Comment

by:LKaushal
ID: 21786632
Hi Douqdog, this is because ICA Client on Citrix1 is configured correctly and passing through the correct credential, however, ICA Client on citrix2 has some issue. Did you check if it's only with the PN Agent. What happen if you run Full PN inside 'Published Desktop' of citrix2? If it works then we could say that it's PN Agent issue only and concentrate on PN Agent only.
Also, as you mentioned Pass-through is working fine with on the Citrix1 server then it is not the server side issue anymore and it's more a ICA Client issue on Citrix2. Let us know your finding about the Full PN (ICA Client version??)and also if possible, kindly test ICA Client v11.0 Beta (avaiable on Citrix download side).
0
 

Author Comment

by:dougdog
ID: 21789693
hi there,
i will test this tomorrow however all my apps are published via pna
so if there was a problem with the agent on citrix 2 how am i able to open apps on citrix2
ie when i run the published desktop on citrix2 i can open apps on citrix2
0
 

Author Comment

by:dougdog
ID: 21789710
ps i def do not have a password save option
all i have is the following
general
domain restriction
authentication type
kerberos authentication
0
 

Author Comment

by:dougdog
ID: 21789843
ps
just to be clear
it is not that im being asked to re enter the username and password for the pnagent prompt it is the actual windows server prompt
0
 

Author Comment

by:dougdog
ID: 21817527
Hi there,
The problem was the following
i ran tscc.msc from the command prompt
under the ica settings it was set for ask for username i changed this and this solved my problem.
I would like to still award the points for all the help i got as sometimes i get very little help for citrix questions.
Thanks again
0
 

Author Closing Comment

by:dougdog
ID: 31466883
Hi there,
The problem was the following
i ran tscc.msc from the command prompt
under the ica settings it was set for ask for username i changed this and this solved my problem.
I would like to still award the points for all the help i got as sometimes i get very little help for citrix questions.
Thanks again
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #XenApp #Citrix Scout #Citrix Insight Services #Microsoft VMMAP #Microsoft ADEXPLORE #Microsoft RAMMAP #Microsoft TCPVIEW #Microsoft AUTORUNS #Microsoft PROCESS EXPLORER #Microsoft PROCESS MONITOR
What if you have to shut down the entire Citrix infrastructure for hardware maintenance, software upgrades or "the unknown"? I developed this plan for "the unknown" and hope that it helps you as well. This article explains how to properly shut down …
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question