Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cannot RDP into machine with error RDPDD.dll failed to load

Posted on 2008-06-13
19
10,349 Views
Last Modified: 2010-09-28
cannot rdp into machine with with error RDPDD.dll failed to load
I have tried sfc /scannow
running xp sp 2
tried replacing with one from another computer in the system 32 dir.
0
Comment
Question by:APPUND
  • 6
  • 5
  • 3
  • +4
19 Comments
 
LVL 7

Expert Comment

by:ottobock
ID: 21778907
Hello,

It may have to do with an ATI driver, or something else. Please have a look here:
http://blogs.technet.com/brad_rutkowski/archive/2008/01/04/systemroot-system32-rdpdd-dll-failed-to-load.aspx

Good luck!
0
 

Author Comment

by:APPUND
ID: 21781927
tried rolling back display driver.
0
 
LVL 7

Expert Comment

by:ottobock
ID: 21782427
Hmm, every single thing I am reading refers to the display driver. Here's another EE post: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Remote_Desktop-Terminal_Services/Q_23130548.html?sfQueryTermInfo=1+%22rdpdd.dll+fail+load%22

Maybe try going to the mfg website and downloading the newest drivers for your PC.

I also found a post mentioned to turn down Hardware Acceleration in display properties - maybe worth a try. Though it did not work for this particular case, it's very easy to try:
http://www.deskshare.com/Resources/articles/dmc_turnoffhardwareacceleration.aspx

One last thought - have you tried running Windows Updates to download and install the newest version of RDP? (newer versions cache credentials and such, a slightly different look to the icon as well)
Good luck - I'll keep looking around and post any additional info I may find.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 7

Accepted Solution

by:
ottobock earned 125 total points
ID: 21782571
Yet another post on EE said to fully uninstall the display driver from Add/Remove Programs and restart. If possible, allowing the driver to reinstall without using the ATI Catalyst. (going off the assumption you are indeed dealing with an ATI video adapter...)

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Remote_Desktop-Terminal_Services/Q_23438949.html

If you have Nvidia - certain drivers have been noted many times to have problems as well.
http://www.dslreports.com/forum/r20628199-XP-Pro-RDP-broke-just-flashes-connection

Of the hundreds of different claims of this issue around the internet - all seem to revolve around that pesky video driver. Hopefully one of these posts helps you out.
0
 

Expert Comment

by:Argorian
ID: 23591213
a bit old, but maybe this solution can help someone.
It worked for me.

If you increase the size of the session image space then you can run remote desktop.

Add the following registry key:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

"SessionImageSize"=dword:00000020
0
 

Expert Comment

by:sharonstroeder
ID: 23898734
Just as an FYI for anyone running into this problem in the future, if you do not want to revert back to an old driver, the registry fix posted by 'Arqorian' worked flawlessly for me. Thanks!
I have an NVIDIA GeForce 8400 GS with driver version 175.16 installed
0
 
LVL 2

Expert Comment

by:STS-Tech
ID: 25016013
Is that 00000020 hex or decimal?
0
 

Expert Comment

by:sharonstroeder
ID: 25016542
to: STS-Tech
That is hexadecimal
0
 
LVL 2

Expert Comment

by:STS-Tech
ID: 25017544
Thanks for the reply- I guessed it was, and it did fix the issue!
0
 

Expert Comment

by:Capperdog
ID: 25283437
Is the fix to add a DWORD Value under the Memory Management key or to create a new key under Memory management?
0
 
LVL 2

Expert Comment

by:STS-Tech
ID: 25291229
DWORD, not Key.
If you have a SessionImageSize dword, just modify it- otherwise create a new one.

Good Luck.
0
 

Expert Comment

by:Capperdog
ID: 25300614
Thanks STS... Problem solved!
0
 
LVL 2

Expert Comment

by:STS-Tech
ID: 25300668
NP- but credit (if not points) goes to Argorian.  Glad I could help, though.
0
 

Expert Comment

by:ScottDare
ID: 25535829
The "SessionImageSize" fix worked just great for a wonky NVIDIA GeForce 9300 GE. Only required a restart. No driver un/re install needed!
0
 

Expert Comment

by:Capperdog
ID: 25536352
It has worked great for me on 3 out of 4 machines. I still have one that has the same symptoms, but this fix has not taken care of it. I even tried to increase the session image size a little more and rebooted agsain, but it still won't paly nice. Any ideas??
0
 
LVL 2

Expert Comment

by:STS-Tech
ID: 25536389
Got and ATI video card laying around?  That'll either fix it, or let you know it's a different problem.
0
 

Expert Comment

by:Capperdog
ID: 25536402
I will check it. Thanks!
0
 

Expert Comment

by:Capperdog
ID: 25720399
Hmmm.... Just got a call from one of our techs. He just tried to apply the fix and it did not work, just like the machine I was working. I checked his settings in the registry and they are correct. I just checked the card and this machine has an ATI Radeon HD 2400 XT card in it. I also checked the machine I was working on and it too has the same card.

Do we think that changing the video card may still be the next step here?
0
 

Expert Comment

by:Capperdog
ID: 25720512
Hold the phone peeps. We just downloaded the latest driver for this card and we are in! It was updated 10/04/09 and has fixed the RD issue with these machines.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question