Solved

SMS fails to process or update packages

Posted on 2008-06-13
7
6,725 Views
Last Modified: 2013-11-21
I'm getting the error message "SMS Distribution Manager failed to find or create the defined share or volume on the distribution point ___________ for distribution package ________. "

The solution suggest that I verify at least one NTFS drive with enough free disk space to store the package. Then, verify that the distribution point directory exists, has the proper permissions and is accessible.

I have plenty of space, approximately 84 percent of the drive is free, and that it is accessible. I've used SMS to send out 60 or so windows security patches but these last 8 won't distribute so that they can be installed on the client side.

Where else in SMS should I check for more information on how to remediate this problem? Has anyone encountered this problem before?

Here's an informational message from the advertisement viewer

"The program for advertisement ___ has not yet started because the content for the package ____ has not been acquired. Possible cause: The content for this program must be downloaded into the computer's cache, or the content could not be located.

Solution: If the program is being downloaded, no action is required. The program will start once the download has been successfully completed. If the content can not be located, ensure that a aditribution point with this content is available for this computer. Distribution point availability can be affected by roaming boundary configuration which is used to determine whether distribution points are classified as local or remote, or by enabling distribution points as protected distribution points. "

All of this makes sense since the distribution manager is saying that it can't process the package.

The Message ID from the Distribution Manager is Error 2324
Currently reading through "Troubleshooting Software Distribution" from TechNet

http://www.microsoft.com/technet/prodtechnol/sms/sms2/smssdch8.mspx (Ctrl+F to "Package Creation and Distribution Processes"
)

Now reading through "Scenarios and Procedures for Microsoft Systems Management Server 2003: Planning and Deployment"...
http://www.microsoft.com/technet/sms/2003/library/spgsms03/spsms14.mspx

...referencing for background information.

I've used the "no_sms_on_drive.sms" file/tactic to force SMS to a new server that I just created. Perhaps this will be a viable work-around, but I'd rather a real solution.

Created new distribution site on another server
Removed all other distribution sites
Re-assigned packages to new distribution site
Re-ran advertisements for packages
rebooting test computers to clear connections to servers or any packages they may already be trying to implement.

problem still exists.

digging through security logs, searching for any audit failures related to objects involved with SMS and remediating upon occurrence

The user/service account has FULL permissions to all the distrobution points.
0
Comment
Question by:Butterwood
  • 4
  • 2
7 Comments
 
LVL 29

Expert Comment

by:matrixnz
ID: 21786775
So when you set this package under "Data Access" tab are you specifying a "Share distribution folder" or using Access distribution folder through common SMS package share?

If you select "Share distribution folder" SMS will attempt to place the package on the root of the distribution point i.e. on C:\, D:\ etc.. rather than the default SMSPKGx$ folder where x= the Distribution Point Volume Name.  If SMS doesn't have rights to write to the Root then you would receive this error.  However it also means that there maybe problems with your SMS installation as SMS should have full access to all the distribution point servers, the service account imho should be a member of the Domain Admins.

Anyway hope that made sense and helps with a solution.

Cheers
0
 

Author Comment

by:Butterwood
ID: 21793883
Thank you for your comment.

I am using "Access distribution through common SMS package share." I have tried the alternate method with no success.

The account is a member of the Domain Admin group. I have manually checked and explicitly granted the account rights to the root of the volumes.
0
 
LVL 29

Expert Comment

by:matrixnz
ID: 21819497
Try running the SMS 2003 Tookit 2 'Management Point Troubleshooter' just to check the communication between the Primary and Secondary Servers.

Cheers
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:Butterwood
ID: 21834940
I got tired of troubleshooting and decided to reinstall.

Plan B

I performed a full backup of the SMS server and SQL server just in case I need to roll-back.
I uninstalled SMS rebooted and started a reinstall. The installation fails with an error saying that it can't write tables to the database. When you check the database there will be tables populated with no data in them. Perhaps it's failing to write data to the tables rather than not being able to create the tables themselves. An associate informed me that SMS 2003 does install onto  SQL2005. This was confirmed by various other "internet" threads and a couple of pages on Microsoft's website. Lesson learned.

Plan B v1.5

I then installed SQL 2000 on the same box, a side-by-side install. I created an instance name just for me new SMS installation. Windows told me that I needed to patch SQL to SP3, no big deal. I had the SP4 patch ready. I tried to tell the installation wizard to use my new instance of SQL but there was no field that was appropriate in the installation wizard. Me being smarter than the computer...I tried to tell it where it was, but that didn't work. Here's Lesson#2 The SQL instance pm which it is installing MUST be the default instance. The SQL server had other important databases running on it so I couldn't blow it away for the sake of little pissy SMS.

Plan B 2.0

Install SQL 2000 on the same server of SMS.
Success

Patch SQL2K to SP4
Success

Install SMS
Success

Patch SMS to SP2
Success

Install ITMU before making the fatal error of trying to install ITMU after SP3
Success

All components installed configuring system settings.
0
 

Author Comment

by:Butterwood
ID: 21858167
Problem still exists even after a new install and new installation of SQL.
0
 

Accepted Solution

by:
Butterwood earned 0 total points
ID: 21886686
I found that by adding the "Everyone" builtin group to the package directory's share permissions, in addition to having the SMS service account assigned, the errors ceased and packages processed normally. I recognize that using the "everyone" group is generally a "no-no." I substituted "Authenticated Users" for "Everyone" with read-only permissions and it's still operating without error.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
DHCP restore question Server 2003 to 2012 3 47
Moving RDP Server to New Server. 3 46
DHCP server 6 49
need help with active directory 4 26
The question has been asked on multiple occasions as to how best to do printing in a remote desktop or terminal services environment.   It seems that this particular question has plagued several people and most especially as Terminal Services, as…
Some time ago I faced the need to use a uniform folder structure that spanned across numerous sites of an enterprise to be used as a common repository for the Software packages of the Configuration Manager 2007 infrastructure. Because the procedu…
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now