Laptop insists on booting from external USB20 drive despite having set BIOS boot order.

I have to disconnect the Iomega to boot - otherwise it sits there trying to boot from this Iomega.

I have a Dell 8600 laptop.  I am running XP Pro.
Details:  I am using a Port Replicator.  It has one USB port.  I also have a USB hub with 4 ports.
It doesnt matter which ports the Iomega is attached to.  I still have to turn the Iomega off to boot.
DFlaschenAsked:
Who is Participating?
 
jhyieslaCommented:
What is the boot order that you have set in the BIOS?
0
 
DFlaschenAuthor Commented:
Probably
Hard disk (C:)
CD-DVD ROM
USB

I know about boot orders.  I've checked it.
Do you need me to reboot and write the order down?  Or is what I wrote above sufficient?  
I understand that if what I wrote is not true, it will continue to fail - but it is true.  Still, if you need this, I'll reboot and provide it exactly.  thanks.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
jhyieslaCommented:
The only reason I think you should go into the BIOS and check for sure is that there are many times I have really been sure about something, only to find out that the computer had another idea and for some reason what I thought I had put in had changed or I forgot to save it off.
0
 
DFlaschenAuthor Commented:
OK.  If that's the only reason then "Yes.  I just rechecked it" and it is as I've said.  In fact, before this recent check, I checked it 5 times because I have experience with Boot Order.  And, just like you, I've been SURE I checked something and hadn't.  But this time it's true (HDD, CD-ROM, USB).
0
 
jhyieslaCommented:
OK...assuming that the USB drive you have is a HDD and it is bootable, some systems will also have in the BIOS not only a boot order, but some order or definition of what HDD are in the system.  Have you checked to see how you BIOS sees what's attached and if it sees the USB HDD as that and if it is ordering it as the Primary master instead of your internal disk?  Could be that the BIOS is classifying USB as USB flask stick and with a real HDD in the USB slot the BIOS could see it as a HDD and if there is another place in the BIOS to define HDDs it could be defining it in front of your internal drive.
0
 
nobusCommented:
is there any iomega software installed?   check it for any boot issues - it may override the bios settigns
0
 
nobusCommented:
also, some older laptops just do NOT boot if any usb device is attached and ready...can you check that with another usb device (printer ?)
0
 
DauheeCommented:
depending on your BIOS type/version there should also be an option to disable booting from usb. BIOS, like any other software can have bugs in it. Disabling should definitely work :)
0
 
DFlaschenAuthor Commented:
No Iomega software is installed
There are other USB devices (Epson CX-4800 All-In-One printer) that do not interfere with booting.
0
 
jhyieslaConnect With a Mentor Commented:
Did you check to see if your BIOS sees your USB HDD as a HDD and perhaps has moved it to the "Primary master" designation or something similar?  Even if the boot order is OK, if it sees it as a higher level drive it may make the USB HDD the HDD of choice.
0
 
DFlaschenAuthor Commented:
I still haven't had a chance to test.  Thanks for your patience.
0
 
DFlaschenAuthor Commented:
Truth be told, I never tried these suggestions.  I just found a workaround which is good enough for now.  Sorry.  Thanks.
0
 
nobusCommented:
and what was the workaround ?
0
 
DFlaschenAuthor Commented:
The workaround was (pretty boring) -
Remember - this was all based on LAZINESS - my reluctance to get off my ----.
This is a Dell Inspiron laptop, with a D-View stand and docking station.  It has a 4-port USB hub.  The hub is hard to reach and the external drive preventing the boot is on the floor.  So, my lazy choices were:
  Get on the floor and unplug the USB cable from the back of the external drive, OR
  Reach for the hub and unplug it there.
Then I discovered that there was another, unused USB port on the docking station, which is easy to reach.  
So lazy me now just plugs / unplugs the external drive's USB cable from the reachable docking station.
BTW;  Once the Windows logo appears, you can plug it back in.  So the wait is like 10 seconds
0
 
nobusCommented:
tx for the feedback !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.