Solved

Enable local and internet access on wireless connection

Posted on 2008-06-14
3
2,878 Views
Last Modified: 2013-11-09
I have a wireless connection on a Vista laptop that was incorrectly set up as local access only.  How do I change the access from local  to local and internet access?

I have tried everything I can think of, but have been unable to change the settings, and need internet access.

I have checked the wireless access point and it works with other computers that have local and internet set up.

Does anyone have a quick fix for this?
0
Comment
Question by:jguilbeaux
3 Comments
 
LVL 5

Accepted Solution

by:
DanoliSolutions earned 500 total points
Comment Utility
I found this that I think is relative but do not have a Vista machine too had to test.

You must be sure that your network is Private. Go to Control Panel, Network and Sharing Center. Find your router and see where it says (public network)? you must change this to Private. There is blue print
to the far right of the icon for your rounter and it says Customize.
Click on Customize and select Private. Then close out.

Next, go to (same box) in case you closed it out, Control Panel, Network and Sharing Center. Under the router name, Connection, to the right of Connection you see Wireless Network Connection (name of
router), then to the right of that you see in blue letters View status.  Click on View status. the Wireless Network Connection Status box appears. At the bottom of the box there is a box for Properties, click
on it (NOT WIRELESS PROPERTIES). Under the Networking tab highlight Internet Protocol Version 4 (TCP/IPv4) and click on Properties. Under the General tab, select Obtain an IP address Automatically, Obtain DNS server address automatically. Select OK and reboot IMMEDIATELY.

When it boots back up you may already have the internet, or you may be asked to decide on a Private, or Public...select Private.
0
 
LVL 44

Expert Comment

by:Darr247
Comment Utility
Did you already try removing that wireless connection, then creating it again choosing Local and Internet Access?

Is the vista laptop getting its IP address via DHCP or is it a static IP?

Have you applied SP1 for vista? - http://support.microsoft.com/kb/935791

Have you applied the fix in this KB article? - http://support.microsoft.com/kb/941649

Solutions found elsewhere:
#1
The next time you get local only, try this:
Open the "Netowrk and Sharing Center"
Click on Customize next to your network
In the "Set Network Location" dialog box, click on "Merge or delete network locations"
In the "Merge of Delete Network Locations" box, look for a network location with the status "not in use". Delete that network location by highlighting it and clicking the delete button.
Close dialog boxes.

#2
I opened the network connections and right click on the wireless connection and click properties.
In the Wireless connection properties I highlighted ipv4 and clicked properties.
Under the general tab, I left it to default settings which is 'Obtain IP address automatically"
I clicked on the Alternate Configuration tab and set it to user configured.
I set the IP address, subnet, and default gateway manually. I also added Preffered DNS server to the router address and left the rest blank.
I clicked on OK and close all the windows and rebooted the computer.
After reboot I opened network and sharing center.
Access was 'local' for a while then the diagram changed and the red x was removed.
Unidentified network was changed to my network name.
Then I tested my connection and browsed to a couple of sites and now I can access the internet.
Rebooted a couple of times and it still worked.

#3
Full Format
Install XP Pro

#4
Disable power saving in wireless card's Advanced properties/tab. i.e. do not allow vista to reduce power to save battery.

#5
http://support.microsoft.com/kb/928233 (if this is the problem you would get a 169.254.x.x IP, not 'local access only')

#6
change the channel on your wireless G router to 1, 6 or 11. It's probably one of those already; try one of the other 2.

#7
A technet article probably too technical for the average user, but useful for tech oriented users with any vista wireless problems. - http://technet2.microsoft.com/WindowsVista/en/library/3ed3d027-5ae8-4cb0-ade5-0a7c446cd4f71033.mspx?mfr=true

#8
http://support.microsoft.com/?id=941649

#9
A)  Go to "connect to a network" and right click on your wireless network and select "status"
B)  Select the bottom area (under "activity") "properties"
C)  In the "Wireless Network Connection Properties" window select the "Networking" tab and highlight IPv4 and select "Properties" at the bottom.
D)  In the "Internet Protocol Version 4 (TCP/IPv4) properties" window select the "Alternate Configuration" tab and then select "User Configured" and fill in the top 4 lines with the correct information for your network.  The most important one which I think is causing this problem is the "preferred DNS server" which VISTA does not seem to capture unless you give it to them here.  
E)  OK your way out.

#10
A) I put my Vista based PC on ebay and sold it (unfortunately at a loss).
B) I'm using the money I made selling that PoS to buy an Apple MacBook or MacBook Pro sometime next week (haven't decided which yet).
C) I know it works because my old Powerbook can STILL connect to any Internet connection WITHOUT ANY PROBLEMS.
If I need to run any PoS M$ software (Pretty much NONE!) I will be installing XP via VMware Fusion or Parallels.

#11
Uninstall 2nd party Anti-Virus and Firewall.
Try connection (enable windows firewall).
Reinstall Anti-Virus, get all its updates.
Try connection again (a few hours, not a few minutes).
Disable windows firewall, reinstall firewall, get all its updates.
Try connection again.
If problem returns at this point, uninstall 2nd party firewall and go back to using vista firewall.


#12
A)  Go to Control Panel, System
B)  Under "Computer name, domain, and workgroup setting" select "Change Settings"
C)  The system will prompt you for the network type:  Home, Business and Public
D)  Select Home


- - -

I also found references to disabling the auto-scaling, but that's from pre-SP1, so save that as a last resort (http://support.microsoft.com/kb/934430).

Most complaints about this seem to have dried up around the release of SP1, so hopefully that will fix it for you.
Have also heard of SP1 not finishing properly, so if you already have SP1, try uninstalling it and applying it again.
0
 

Author Closing Comment

by:jguilbeaux
Comment Utility
Thanks for the information.  Worked like a charm.  I had done everything except reboot the laptop.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now