[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Enabling CIDR notation on Cisco 877

Posted on 2008-06-14
5
Medium Priority
?
1,075 Views
Last Modified: 2012-08-13
Hi,

I have a Cisco 877 running c870-advipservicesk9-mz.124-15.T4 and am attempting to get it to handle CIDR notation for ACLs, etc and have had no luck. Have issued both 'ip classless' and 'ip subnet-zero' however neither show up in the running configuration.

What am I missing?
Building configuration...
 
Current configuration : 2961 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Oblivion
!
boot-start-marker
boot-end-marker
!
no logging buffered
no logging console
!
no aaa new-model
!
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.250.0 10.0.250.60
ip dhcp excluded-address 10.0.250.250 10.0.250.255
!
ip dhcp pool LAN
   network 10.0.250.0 255.255.255.0
   dns-server 10.0.250.254
   default-router 10.0.250.254
   lease 2
!
ip dhcp pool dhcp_static_matt
   host 10.0.250.10 255.255.255.0
   client-identifier 0100.18f3.0d78.eb
!
!
ip domain lookup source-interface Dialer0
ip domain name Xembler
ip name-server 203.12.160.35
ip name-server 203.12.160.36
ip inspect name myfw tcp
ip inspect name myfw udp
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username admin privilege 15 secret 5 <password>
!
!
archive
 log config
  hidekeys
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface ATM0
 no ip address
 ip virtual-reassembly max-reassemblies 1024
 no ip mroute-cache
 load-interval 30
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
 switchport access vlan 2
!
interface FastEthernet1
 switchport access vlan 2
!
interface FastEthernet2
 switchport access vlan 2
!
interface FastEthernet3
 switchport access vlan 2
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 10.0.250.254 255.255.255.0
 ip accounting output-packets
 ip nat inside
 ip virtual-reassembly
!
interface Dialer0
 ip address negotiated
 ip access-group borderfw in
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap password 0 <password>
 ppp pap sent-username <username> password 0 <password>
 ppp ipcp route default
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dhcp
!
!
no ip http server
no ip http secure-server
ip dns server
ip nat inside source static tcp 10.0.250.10 15881 interface Dialer0 15881
ip nat inside source route-map natmap interface Dialer0 overload
!
ip access-list extended borderfw
 permit tcp any any eq 22
 permit icmp 125.254.24.0 0.0.0.255 any echo-reply
 deny   icmp any any net-unreachable
 permit ip any any
ip access-list extended natlist
 deny   ip 10.0.250.0 0.0.0.255 10.0.80.0 0.0.0.255
 permit ip 10.0.250.0 0.0.0.255 any
!
!
!
!
route-map natmap permit 10
 match ip address natlist
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login local
 transport input all
 transport output ssh
!
scheduler max-task-time 5000
end

Open in new window

0
Comment
Question by:rslqld
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21786928
The only place a mask will show up in CIDR notation is from a "show int" or "show ip int".
0
 
LVL 5

Author Comment

by:rslqld
ID: 21787019
Really? On another router I have, I've the option to specific mask in CIDR....odd.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21787093
When you define the IP address? What model?

The only devices I've seen where you can do that are the CatOS switches and PIX's. Never seen a Cisco Router that allows it.
0
 
LVL 23

Accepted Solution

by:
Mysidia earned 750 total points
ID: 21787518
The reason they don't show up in the running configuration is that "ip classless" and
"ip subnet-zero"  are both on by default in 12.4.

An item you specify in your config that is its default setting will not show up in 'show run'

The latter option (subnet-zero) effects whether or not you can assign an interface to the subnet with all subnet bits zero.

The classless option causes the router to perform classless routing.
Neither of these options effect the notation you can use when entering an address into the config.

In fact, there is (unfortunately) no command to allow you to enter subnets in  CIDR format (slash notation).

The notation you use for entering an address for a route or access-list entry when you config a Cisco device cannot be changed.  The allowed notation is not configurable.


What you _may_  set is the display format for ip addresses.

This is done in normal exec mode (not config mode) and effects how
addresses are _displayed_  when you use a show command.

term ip netmask-format bitcount

OR

term ip netmask-format decimal

OR

term ip netmask-format hexadecimal


0
 
LVL 5

Author Comment

by:rslqld
ID: 21789535
Cheers for the input. I will put my 878 doing it down to it being a weird image. T trains never do work right :)
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question