Solved

How can I use LAN ports ONLY on a Linksys Wireless WRT54G?

Posted on 2008-06-15
8
498 Views
Last Modified: 2010-04-21
I want ALL packets to stay on the LAN.  I tried putting in a static route:

0.0.0.0
0.0.0.0
192.168.1.1

But it said "invalid destination IP".

The reason I want to do this is I am hooking up the WRT54G to the inside NIC card of an ISA2004 server, which is acting as the gateway to the internet.  

So I don't want to have a second gateway on the network and I don't want to have a second set of inside addresses.

Is there a way to make this work?

If it can't be done with the WRT54G, is there a wireless router I can buy that allows me to do this?

Thanks.
0
Comment
Question by:gateguard
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 6

Expert Comment

by:Nyah247
ID: 21788187
Have you tried to use the ISA server as your default gateway on your linksys.
0
 

Author Comment

by:gateguard
ID: 21788216
I'm not sure I understand.  The linksys has two configuration settings, one of the LAN the other for the WAN (or internet).

If I set up the LAN to have this address:
192.168.1.1
255.255.255.0
192.168.1.10

And the inside nic of the ISA server to have this address:
192.168.1.10
255.255.255.0
192.168.1.1

And have the wireless give out addresses in the range 192.168.1.100-150.

And then connect to the wireless with a laptop and try to go to the internet, I can't get to the internet.

It seems the wireless is trying to route the laptop's request out to its "internet" port, even though it's not plugged in.  Or anyway, it's failing.  (I can get to the internet from the ISA server.)

I'm not seeing what else I can do to route all packets on the wireless to 192.168.1.10.

0
 
LVL 6

Accepted Solution

by:
Nyah247 earned 167 total points
ID: 21788338
Ahh...  The ISA server should not have an internal gateway just one on the external interface.  You need to make sure that you setup the routing tables on ISA for internal.  Check this out for how to add routes:

http://forums.isaserver.org/m_2002050136/mpage_1/key_/tm.htm#2002050136

Check out the info about static routing with linksys here:
http://help.expedient.com/broadband/linksys_advanced_options.shtml
0
Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

 

Author Comment

by:gateguard
ID: 21788439
Thanks but I think I've got the ISA correctly set up.  If I take out the router, plug in a switch in its place, plug a PC into the switch and manually give it an ip address of 192.168.1.100, then that PC can get to the internet.

But if I remove the switch and put the wireless router back in the circuit, then I'm back to the problem of not being able to get to the internet from an inside computer.

The problem appears to be that I can't enter this static route on the WRT54G:
0.0.0.0
0.0.0.0
192.168.1.10

Sending all packets, whatever their destination, to the ISA server.

When I try to enter that route, I get "invalid destination IP address".  

Of course, in the "real" world, 0.0.0.0 is NOT an "invalid destination IP address".
0
 
LVL 44

Expert Comment

by:Darr247
ID: 21788770
Did you try plugging the ISA's inside NIC into one of the WRT54G's LAN ports, not its WAN/Internet port?
0
 
LVL 44

Assisted Solution

by:Darr247
Darr247 earned 167 total points
ID: 21788796
> If I set up the LAN to have this address:
> 192.168.1.1
> 255.255.255.0
> 192.168.1.10

Just for clarity, that's
LAN interface - 192.168.1.1
Subnet mask - 255.255.255.0
Gateway - 192.168.1.10

Correct?

If so, I'm not understanding

> And the inside nic of the ISA server to have this address:
> 192.168.1.10
> 255.255.255.0
> 192.168.1.1

i.e. The 'inside NIC' should NOT have a Gateway IP of 192.168.1.1


Assumption - You've also restricted the scope of any other DHCP server[s] to not hand out addresses from 100-150, and don't have any static IPs in that range, so you won't end up having devices with duplicate IPs 'inside'.
0
 
LVL 88

Assisted Solution

by:rindi
rindi earned 166 total points
ID: 21788820
Just give the router a static IP on your LAN's subnet. Make sure that IP isn't served by your DHCP server and disable the DHCP server of your router. Connect it to the LAN via it's LAN port. Don't use the WAN port.
0
 

Author Closing Comment

by:gateguard
ID: 31467325
Thanks for all your help.  One thing I added to the mix was turning on RIP on both the server RAS and the Linksys router.  That finally gave me the route I needed on the Linksys.
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to perform a hard reset on your router. Usually this is most-useful on wireless routers, but the same concept applies to nearly all home/SOHO routers. This process will return the router to factory defaults, so record your…
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
In a recent question (https://www.experts-exchange.com/questions/28997919/Pagination-in-Adobe-Acrobat.html) here at Experts Exchange, a member asked how to add page numbers to a PDF file using Adobe Acrobat XI Pro. This short video Micro Tutorial sh…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question