Exchange Server 2003 Configuration

Can someone please help me to configure Microsoft Exchange Server 2003. I have installed it on to a server 2003 server and followed a basic setup guide. I can send email internally, but cannot send or receive externally. I purchased a domain name: homenet2k3.co.uk from 1and1.co.uk and would like to use that so username@homenet2k3.co.uk can send and receive wxternal emails. Someone mentioned smething about mx records which i looked up on 1and1 website which seem to be:

Domain name  homenet2k3.co.uk
IP Address (A-Record)  82.165.61.101
Name server 1  ns59.1and1.co.uk
Name server 2  ns60.1and1.co.uk
Mail server 1  mx00.1and1.co.uk, 10
Mail server 2  mx01.1and1.co.uk, 10

Can someone please help me configure exchange?

Thanks
LVL 2
andrewjones1987Asked:
Who is Participating?
 
tigermattConnect With a Mentor Commented:
First of all, you need to ensure your homenet2k3.co.uk domain is configured in your recipient policy. If it isn't you can do so as per http://support.microsoft.com/kb/249299. You only need to do this if your user accounts don't yet have @homenet2k3.co.uk email addresses on their Email Addresses tab.

You will need to configure your MX records to send the mail direct to your Exchange Server. Within the 1and1 control panel in the "Domains" section, you will first need to drop-down the menu beside new and select the New Subdomain option. The new subdomain should be mail.homenet2k3.co.uk. Once the new subdomain is created in the Domains section, check the box beside it and press on the DNS button to edit DNS configuration for the domain. Press the Edit button and set the IP address (A record) to the external static IP address provided by your ISP. OK back out.

Once the DNS changes are propogated - which can take up to 24 hours - you then need to edit the DNS on your main homenet2k3.co.uk domain. This time, leave the A record in tact, but change the Mail Server MX records. Delete any 1and1 MX records, and then just set the MX record to be, and to only be, mail.homenet2k3.co.uk with a cost of 5.

The last step is to forward port 25 through your router/firewall to the internal static IP of the Exchange Server. Guides on port forwarding can be found on a per-router basis at http://portforward.com/

That will get mail flowing into your Exchange Server. If you don't have a static IP address, you'll need to get one from your ISP, or go through a Dynamic DNS provider.

-tigermatt
0
 
andrewjones1987Author Commented:
i don't have a static ip, but i setup a dyndns with the following: andrewjones87.homedns.org
0
 
tigermattCommented:
In that case, all you need to do is open the 1and1 control panel and edit the DNS on your homenet2k3.co.uk domain straight away (don't do the mail. domain). Set the MX record to be andrewjones87.homedns.org with a cost/preference of 5.

You'll then need to still do the port forward on port 25 through your router, but then you'll be up and running.

-tigermatt
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
andrewjones1987Author Commented:
So on homenet2k3.co.uk what would the other dns settings be and where would i need to put "andrewjones87.homedns.org with a cost/preference of 5"

thanks
0
 
andrewjones1987Author Commented:
these are the current settings, so what goes where?

Domain name  homenet2k3.co.uk
IP Address (A-Record)  82.165.61.101
Name server 1  ns59.1and1.co.uk
Name server 2  ns60.1and1.co.uk
Mail server 1  mx00.1and1.co.uk, 10
Mail server 2  mx01.1and1.co.uk, 10
0
 
tigermattCommented:
When you access the DNS editing page in the 1and1 Control Panel for your domain, the only thing you need to change is the MX record. Choose the red underlined option for "Other Mail server", then enter your andrewjones87.homedns.org into the box provided (underlined blue).

You can access the interface I took a screenshot of below by highlighting your domain in "Domains", then dropping down the menu beside DNS and press "Edit DNS".

-tigermatt
1and1dns.jpg
0
 
andrewjones1987Author Commented:
thanks. what setting do i need to put in the SMTP connector? at the moment it is like below:
untitled.JPG
0
 
tigermattCommented:
The SMTP connector sends mail out to the Internet. Since you're on a dynamic IP you must use the 1and1 SMTP server as you have already configured. The only additional step is to enter the credentials to authenticate with 1and1. To do this, open the "Advanced" tab, uncheck the box "Send HELO instead of EHLO" (if checked), then press Outbound Security. Choose Basic Authentication, press the Modify button, and enter the email address and password of a mailbox you have configured in your 1and1 account. OK out twice. Still on the Advanced tab, ensure "Do not send ETRN/TURN" is selected. Press OK.

Note that the mailbox you set up at 1and1 for this is merely a placeholder. Since you've changed your MX records the mailbox will not receive any mail. It is simply to give you some credentials to authenticate and send your mail out with.

-tigermatt
0
 
andrewjones1987Author Commented:
so does that mean that i just create a dummy email address like user@homenet2k3.co.uk to use for authentication?
0
 
tigermattCommented:
Yes, that's correct. Open the Email tab at 1and1 and add a mailbox there. It needs to be a mailbox with a password - it can't be an alias or forward though.
0
 
andrewjones1987Author Commented:
thanks for your help
0
 
tigermattCommented:
Feel free to close and assign points when you're ready :-)
0
 
andrewjones1987Author Commented:
works great. i have implemented web based forms for owa using certificate, but i get the error below in the screenshot, but if i select continue then its fine. do you know how to stop error?

thanks
untitled.JPG
0
 
tigermattCommented:
You're getting that message because you have a self-signed SSL certificate, and it is not trusted by default in Internet Explorer. The only effective way to eliminate it is to purchase an SSL certificate from a third party - GoDaddy do them incredibly cheap: https://www.godaddy.com/gdshop/ssl/ssl.asp?ci=8979.

You would have to purchase the certificate for the domain andrewjones87.homedns.org - and then to eliminate the error you would need to ensure you always access OWA using andrewjones87.homedns.org/exchange.

I still have a self-signed SSL certificate on my home Exchange Server - it's really only if it's going to be used by a company or other people that you'll need to spend money on a trusted certificate.

-tigermatt
0
 
andrewjones1987Author Commented:
so do you get the error also and select continue?

also if my internet connection goes down and people send me a message, would i still receive the messages when the connection is re-established???
0
 
Compaq_EngineerCommented:
What was the server name you specified on the certificate and also where did you obtain the certificate from?
0
 
andrewjones1987Author Commented:
i created it with my server name
0
 
tigermattCommented:
Yes, my Exchange Server is just used by myself and my family at home, so I don't see it necessary to spend money on an SSL certificate. I just press Continue and everything will work fine.

If your internet connecton is down (or your IP address changes), the sending mail server will hold the message for up to 48 hours, in which time it will keep trying to resend the message. If your Internet connection doesn't come back up within 48 hours, the message will timeout and an NDR sent back to the sender. If your line is going to be off for over 2 days, you can log back in to 1and1 and change your DNS to point back to their mail servers. Using a catch-all mailbox (*@homenet2k3.co.uk), you can get all the mail at 1and1 until the connection is restored.

I was once away in Majorca for a week and my router crashed on the first day of the holiday - fortunately I logged in remotely that evening, realised I couldn't log in to OWA and was able to change the DNS configuration from this Internet Café so I could at least get my emails whilst I was away and they wouldn't get NDR'd!

-tigermatt
0
 
tigermattCommented:
The reason the certificate is failing is because you have generated it yourself - and Internet Explorer doesn't trust it. The only way to get around this as I've said is to either get a 3rd-party one, or you could import the certificate into IE, but that would have to be done on every PC you access OWA from in order to suppress the error.

I just live with it ;-)
0
 
andrewjones1987Author Commented:
How do you setup a catch all mail box and what would the username be?

On my exchange I have public folders setup with a shared calendar, when opened in OWA it defaults to open in 1 day view, do you know how to open in monthly view by default.

Thanks for your help tigermatt
0
 
tigermattCommented:
This is a catch-all at 1and1 - the email address would simply be an asterisk followed by the domain - so *@homenet2k3.co.uk
Create it just like any other mailbox in the Email tab of the 1and1 control panel - you can use that (along with its password) as your authentication mailbox for the SMTP connector too.

I'm not aware of a method of changing the default calendar view though - I've checked in OWA options and OWAAdmin if there's a method of changing it, but it would appear not. I think that's something you're going to have to change each time you login, I'm afraid!

-tigermatt
0
 
andrewjones1987Author Commented:
hi tigermatt,

thanks for your help.

in your opinion, should i create a mailbox *@homenet2k3.co.uk now and use it for my authentication?

if internet to down longer than 48 hours, then do i only have to change mx mail record back to 1and1.co.uk default?

then what happens to messages when my internet is back on and i change setting back, would all email automatically go to correct mailboxes or what?

thanks
0
 
andrewjones1987Author Commented:
the messages sent whilst no internet i mean
0
 
tigermattCommented:
I would do that - at least then you have the catch all in position, just in case.

Yes, if the internet is down for more than 48 hours, you just change the MX record back to the 1and1 record within the first 24 - 36 hours. That will give time for DNS propogation to take place.

When you change the setting back, all the new mail will then start flowing back to the server, but any mail in the catch all will wait there until you download it to an Outlook client and send it to the appropriate mailboxes. Normally, the Internet connection won't be offline that long though :-)

Matt
0
 
andrewjones1987Author Commented:
so email sent whilst offline that goes into cathall mailbox will not be downloaded by owa then when back online?

thanks
0
 
tigermattCommented:
No, 1and1 cannot be configured to send it on to Exchange when it comes back online. Since 1and1 would be the end point for the mail delivery when the 1and1 MX record is configured, that would be the last place it would be delivered to without your intervention.

If it's any reassurance, my Internet connection fortunately has never been off for more than 48 hours, and I've only ever had to use the catch-all once when, like I say, the router crashed and I was no where near home to reset it.

-tigermatt
0
 
tigermattCommented:
That's not entirely true - what I meant to say was that my Internet connection has been off for more than 48 hours once before, but I've been able to get the MX record changed reasonably quickly and kept the distruption to mail flow to a minimum.

I forgot to mention the secondary MX store-and-forward facilities as an automatic failover alternative. I don't use one of these (yet), but effectively how they work is you go to a company and purchase their backup MX package. You configure their MX record on your domain at 1and1 - but give it a higher preference than the existing MX record (perhaps cost 10, since higher cost number = lower preference). By doing this, if your first preference MX record is ever uncontactable, the secondary MX record will be contacted and mail transmitted to them. When your Internet connection is back online and the server contactable, the backup MX provider sends all the mail it has received on to the server, as if nothing ever happened. This would all happen automatically, although it will require a registration fee. I know No-IP offer this service: http://www.no-ip.com/services/managed_mail/backup_mail.html

-tigermatt
0
 
andrewjones1987Author Commented:
thanks - just one more thing - i have created a public calendar and it seems all users can add appointments. do you know how to prevent this and assign the edit facility to a security group???

thanks
0
 
tigermattCommented:
You'll have to find the Public Folder in Exchange System Manager (it'll be within Your Server > Public Folder Store > Public Folders), view its Properties. Within there, I forget where it is, but there is an option around somewhere in that properties box which allows you to edit the permissions on that Public Folder as you wish.
0
 
andrewjones1987Author Commented:
found it thanks for all of your help

regards

Andrew
0
 
tigermattCommented:
Andrew,

That's fine, you're most welcome - I guess you can close this and assign points?!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.