File Permissions when Importing from USB Media

When importing files from USB media (such as a USB camera or USB flash memory stick) using the GNOME Copy/Paste feature, or dragging and dropping, the permissions for the imported files default to:

user: read-write
group: none
others: none

I need for these files to default to the following permissions:

user: read-write
group: read
others: read

I need for this to happen without any user intervention as the users of this machine are not literate enough and will not understand this procedure. It is to enable these files to be shared through the uPnP/DLNA server MediaTomb.
LVL 3
azcn2503Asked:
Who is Participating?
 
http:// thevpn.guruConnect With a Mentor Commented:
Try to execute
umask 033

and then copy those files

If that works you can simply add that command to ~/.bashrc
0
 
torimarConnect With a Mentor Commented:
You may have to edit the global mount options in the Gnome schema.

Open /var/lib/gconf/defaults/%gconf-tree.xml, search for "vfat/mount options" and change umask from 077 to 033. Save and reboot.

Good luck.
0
 
kevpattsCommented:
Did this work?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.