Solved

Getting an error message, "530 User test cannot log in, home directory inaccessible, Login failed"

Posted on 2008-06-15
9
1,941 Views
Last Modified: 2013-12-02
I have setup an Isolated users ftp site but when I try to login as different users, I get the following message:

530 User test cannot log in, home directory inaccessible.
Login failed.

Here are the steps I followed to create an Isolated users ftp site:

Created a new FTP site
Entered the Description
Entered the IP address and the port 21
Chose "Isolate Users"
Assigned a path, D:\level1\level2\level3\
Assigned Read & Write access.
Clicked Finish

Created four "Virtual Directories".
Chose Aliases
Assigned a path to their directoried in the D drives
Assigned Read & Write access

User name & Virtual directories aliases are EXACT same.
The folder name (under D drive) is little different.  
      i.e.        user name & Virtual directory Alias: test
            Directory name: w_test

These users have full access to these directories.

My Inetpub is under C drive but I picked the path for my MAIN FTP site (w/ isolate users) as "D:\" drive with 4 or 5 level down directory.
The folders I am trying to share are under D drive atleast four or five level down
i.e. D:\level1\level2\level3\w_test

While creating above users, I even assigned the "local path" to the folder I am tryin to use for FTP under "Profile", Local path" (under computer management, Local users & groups).

The reason I need to have the ftp folders for these users in Drive is that they need to upload their html files for their websites.

I am using Windows 2003, Sp2.

Here are other FTP settings:

A directory located on this computer: selected

Local path: D:\level1\level2\level3

Allow anonymous connection: unchecked
Allow only anonymous connection: unchecked

Read, write & Log visits: checked
Directory listing style: MSDos

If I create a normal website with an assigned user, it works fine.  I checked microsoft website it had me change two things, once was to add these users to "Allow Logon Locally" and there was another thing that i can not remember.

Any help will be appreciated.
Thank you,
0
Comment
Question by:Salman121
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
9 Comments
 

Author Comment

by:Salman121
ID: 21789087
Is my problem because of different location than default?  I am choosing totally different location than inetpub or the default location for the ftp users/data?  Does that matter?

0
 
LVL 57

Expert Comment

by:giltjr
ID: 21792635
Have you followed http://support.microsoft.com/kb/555018?

When using isolated user the users must have a "home" directory.  If they are logging on with a domain user-id the directory must be:

      "ftproot"\"domainname"\"userid"

If logging on with a local userid (one that is local to the ftp server, not the users computer) it must:

     "ftproot"\LocalUser\"userid"

where LocalUser is the literal LocalUser.  Example:  Your ftproot is D:\FTPROOT, your Windows domain name is AMCEDOM,  and your userid is BGates.  If you are using domain user-id to login  you must have the directory:

      D:\FTPROOT\AMCEDOM\BGates

if BGates is a local userid to the ftp server, then you need:

     D:\FTPROOT\LocalUser\BGates
0
 

Author Comment

by:Salman121
ID: 21797707
Thank you for your assistance.  Yes, I did look up the above Microsoft article but it didn't help, may be because my directory name & structure is not the same.  I did I am not using the default ftp directory, C:\Inetpub\ftproot

However, when i created an FTP site with an isolate users, I chose "D:\level1\level2\level3\" as the path to the home directory (literally this as this is a test env. and it will be something like this in the production)

I have three Local users, user1, user2 & user3

Their directories are as follow:
for user1: D:\level1\level2\level3\w_user1
for user2: D:\level1\level2\level3\w_user2
for user3: D:\level1\level2\level3\w_user3

I even added the "Local path" for "Home folder" in user2's profile as "D:\level1\level2\level3\w_user2" but it didn't help.

My user names & the virtual directory names (alias) are same, but not the actual directory names, do they have to match as well?

Do I need to add "Local path" for "Home folder" under all user's profile?

Thank you,
Sal
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 

Author Comment

by:Salman121
ID: 21797834
As my users are local to the ftp server, do i have to have a directory structure like you mentioned above, "ftproot\LocalUser\userid"?  

Do I have to have a folder name "Localuser", If yes, is there an alternative to it that I can have this folder and may be link to another folder?

BTW, this box is not a part of any domain.  Just a stand alone box and part of a workgroup.
0
 
LVL 57

Accepted Solution

by:
giltjr earned 250 total points
ID: 21798005
Based on what I have read in the link I provided the directory name must be "LocalUser".  Based on what I have read, there is no option to have it be any different.  This is one of the "gotchas" when using Isolated user mode.
0
 

Author Comment

by:Salman121
ID: 21798089
I read somewhere that you can create a link as well?  Is there any suggestion on that if the folder name has to be "Localuser"?
0
 
LVL 57

Expert Comment

by:giltjr
ID: 21798754
Where did you read that?

From what I can tell when using local security you can't change it, it is fixed by MS.  If you were running Active Directory you could set an AD attribute on the userid to change what their home directory is.
0

Featured Post

Get MongoDB database support online, now!

At Percona’s web store you can order your MongoDB database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card. Handle your MongoDB database support now!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
Determining the an SCCM package name from the Package ID
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question