Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Sonicwall TZ190 SMTP Help

Posted on 2008-06-15
7
Medium Priority
?
1,256 Views
Last Modified: 2013-11-30
Hey!

I just upgraded my network's (Windows Small Business Server 2003 with about 20 clients connected) firewall from a Sonicwall Soho3 to a Sonicwall TZ 190. I threw in all the configurations from the last firewall and everything seems to be working fine except i can't send e-mails! The network uses Exchange with Outlook 2003. I can receive them easily but when i try to send one i get the following error:

There was a SMTP communication problem with the recipient's email server. Please contact your system administrator. <mycompany.com #5.5.0 smtp;550 relaying mail to gmail.com is not allowed>

Now i figure it might be a DNS problem and i forgot to add a setting. There's just a billion more settings in the TZ then there was in the Soho. I've gone into the system manager > SMTP server and checked to make sure all the authentication settings are right. I know it has to do something with the firewall i just can't put my finger on the setting. If i plug the Soho3 back in everything works fine(incoming and outoing). Help is much appreciated!

Thanks!
0
Comment
Question by:aegisyuri
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
7 Comments
 
LVL 1

Expert Comment

by:ITscapes
ID: 21796471
Sounds like a policy issue with your TZ190.  Double check your port 25 and possibly port 110 policies on the old soho3 and compare to the policies on the new TZ190.

Hope that helps!

Mark
ITscapes
0
 

Author Comment

by:aegisyuri
ID: 21838261
I've double checked all the policies and i'm still getting the error.

There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <myserver.com #5.5.0 smtp;550 relaying mail to gmail.com is not allowed>

I've tried looking through the help center on the microsoft site and still no success. I've even tried calling their tech help (sonicwall's) but on the weekend they take forever to transfer and don't seem to be much help either.
0
 

Author Comment

by:aegisyuri
ID: 21838400
I just got off the phone with the Sonicwall tech and they said its probably a setting that our isp uses. We use Cox Cable for our ISP and i checked the smtp connector on our exchange server and it has smarthost.coxmail.com as the forward. Is there some setting in the firewall that i need to change to convey this?
0
Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

 

Author Comment

by:aegisyuri
ID: 21839093
I just called Cox and they added our ip to their relay in the database but i'm sure that isn't going to make a difference considering we could send email before we installed the new firewall. And that's pretty much the only advice they can give us...
0
 

Author Comment

by:aegisyuri
ID: 21859988
I've tried everything so far and nothing seems to work. Anyone else have any light on the situation? I know it has to be just one setting.
0
 

Author Comment

by:aegisyuri
ID: 21860062
I've turned on smtp logging to see if that can help shine the light. here are a couple of errors.

This is an SMTP protocol error log for virtual server ID 1, connection #2. The remote host "68.99.120.5", responded to the SMTP command "rcpt" with "550 relaying mail to gmail.com is not allowed  ". The full command sent was "RCPT TO:<aegis@gmail.com>  ".  This will probably cause the connection to fail.

This is an SMTP protocol error log for virtual server ID 1, connection #1. The remote host "68.99.120.5", responded to the SMTP command "rcpt" with "550 relaying mail to cox.net is not allowed  ". The full command sent was "RCPT TO:<irca@cox.net>  ".  This will probably cause the connection to fail.
0
 

Accepted Solution

by:
aegisyuri earned 0 total points
ID: 21861562
So i've narrowed it down to the NAT policies. Sonic OS Enchanced is way more confusing. Here is my NAT policy:

 # Source Destination Service Interface
    Original  Translated  Original  Translated    Original                   Translated     Inbound  Outbound
         Any     Original       Any      HC Server   SMTP   (Send E-Mail) Original         Any Any

and my access rule:
 Zone > Zone Priority  Source  Destination  Service  Action
LAN > WAN        3        Any    HC Server SMTP (Send E-Mail) Allow All

I no longer get the relay error but the emails don't seem to be going out. They're hanging out somewhere in queue?
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello Friends, My friends and relatives always ask me how to delete all the various types of emails at once in our g-mail  or windows live account.  So I researched this topic to find a unique solution to this query.  Here it is for those who do …
Check out the latest tech news, community articles, and expert highlights in August's newsletter.
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question