how to develope java servlets/jsp on linux fedora core 6

hi all,
I'm newbie to java and I need to train myself on it on fedora core 6. tomcat is available on the machine but unfortunately I can't find the sample examples at webapps folder.

my question is can any one of the experts on this site help me and tell me how to install and configure it to work jsp with tomcat .
any help is appriciated and welcomed. I need you help fast also does there is a way to install it and the eclipse IDE using yum utility if the answer is no how can I do it manually because I downloaded this sdk 5 file and it doesn't work when installing

here is my try messages of errors . please help as soon as possible

[root@localhost ~]# cd /work/source/programs/books/opencms
[root@localhost opencms]# ./java_ee_sdk-5_05-linux-nojdk-ml.bin
Checking available disk space...
Checking Java(TM) 2 Runtime Environment...
Error: Could not find the required version of the Java(TM) 2 Runtime Environment.
This application needs version 1.5 or higher of the Java(TM) 2 Runtime
Environment. If the required Java(TM) 2 Runtime Environment is not installed,
you can download it from the following website:
    http://java.sun.com/j2se
Or if you already have the required Java(TM) 2 Runtime Environment
installed, try rerunning this application with the following usage:
    'java_ee_sdk-5_05-linux-nojdk-ml.bin' -javahome <Java(TM) installation directory>

best regards
mohr4000
mohr4000Asked:
Who is Participating?
 
MicheleMarconConnect With a Mentor Commented:
http://java.sun.com/products/jsp/html/jspbasics.fm.html

Tomcat already works with JSP.

Eclipse on Fedora:
http://sourceware.org/eclipse/

About the error you got: did you install Java SDK first?
0
 
girionisConnect With a Mentor Commented:
What happens if you type

java -version

or

whereis java

If it does nto come up with anything you need to install Java as already suggested.
0
 
girionisConnect With a Mentor Commented:
BTW you can install java from here: http://java.sun.com/javase/downloads/index.jsp You need to choose "JDK 6 Update 6"
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.