[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 147
  • Last Modified:

Server 2003: Trying to hide IP address on adapter

I have a Windows 2003 Standard, SP2 server hosting Exchange at a co-location facility.  There are 2 NICs in the server.  One has a 192.168.2.0 address and the other has a 172.16.10.0 address.  The NIC with the 172.16.10.0 address is on the colo provider's internal network and is used by the provider to backup this server.  The NIC with the 192.168.2.0 address is on my internal network and is the IP address I want associated with the machine name in my network.  When I set this up, I didn't want to have 2 A-records for this server, so I went into the Advanced TCP/IP settings for the 172.16.10.0 NIC and unchecked the "Register this connection's addresses in DNS" box.  Problem is, I still have an A-record showing up for the 172.16.10.0 NIC and it's causing problems on my network (the name resolves to the 172.16.10.0 address instead of the 192.168.2.0 address and things like email won't work.)  I've deleted this A-record numerous times, but it keeps showing up.  Shouldn't unchecking that box prevent this from happening, or do I not understand this option?  How can I keep an A-record for the 172.16.10.0 address from showing up?
0
jpalamar
Asked:
jpalamar
  • 3
  • 2
1 Solution
 
Chris DentPowerShell DeveloperCommented:

Is the DNS Service running on that machine?

In theory it's possible to stop it registering the adapter as detailed in this MS article:

http://support.microsoft.com/kb/246804

See Forward and Reverse per adapter. I've had mixed success with that though, still, far more than with the tick box.

Generally though, if the DNS Service isn't local, and the second adapter has no DNS servers listed it won't be able to register regardless.

Chris
0
 
Chris DentPowerShell DeveloperCommented:

Oops, missed a bit.

If you've done all the above, you can deal with it by modifying the DNS Service so it only listens on the 192.168.2.0 interface.

If it can't listen to the update request the problem goes away.

Chris
0
 
jpalamarAuthor Commented:
Chris: Thanks for your quick response. Yes, DNS services are running on this system. I've tried your suggestion and configured the server's DNS settings to only listen on the 192.168.2.0 interface. I've deleted the unwanted A-record. I'll give it until tomorrow to see if it comes back or not.
0
 
Chris DentPowerShell DeveloperCommented:

Fair enough :)

Chris
0
 
jpalamarAuthor Commented:
Chris,  Thanks for your help on this.  This was one of thos situations where I slapped my forehead and thought "Of course!  Why didn't I think of that?"
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now