Solved

No Sound in Sony Vaio Notebook Sigmatel Audio

Posted on 2008-06-16
3
4,355 Views
Last Modified: 2013-11-17
I have a Sony Vaio VGN-SZ79GN. I installed Winxp with SP 2 (disc came with notebook) with the drivers listed on Sony Asia's website. I have installed all updates from Windows Update, except SP 3

My notebook is unable to play any sound once windows is loaded. The startup windows sound plays when I start and log into the computer but no sound is able to be played. I tried playing the Windows sounds via Control Panel - Sounds and Audio Devices Properties- Sounds but get the following error message:

Error: Windows cannot play the %SystemRoot%\media\Windows XP Error.wav file. It may be damaged or may not be a valid sound file. Replace the file and try again.

How can I solve this problem? It's audio appears to be a Sigmatel Audio.

I have also reinstalled the sound driver, but that does not solve the problem. The notebook is capable of playing sounds since the computer is able to play the boot up windows music.

Thanks!
0
Comment
Question by:scrpl
  • 2
3 Comments
 
LVL 2

Expert Comment

by:TheVanter
ID: 21795375
When you reinstalled the drivers, did you uninstall the old ones first?

Try this: Go into the device manager, under sound, video and game controllers and find your sound card. Right-click on any devices that are associated with it and click "uninstall."  After you have done that, click on the icon to search for and install new hardware at the top of the device manager window (a computer with a magnifying glass).
0
 

Author Comment

by:scrpl
ID: 21795767
I tried the method suggested. The sound works after uninstalling and reinstalling the drivers, windows plays the shutdown music when I restart the notebook. However, upon restarting and loading of windows (startup music plays) I still do not get sound and I still get the same error messages
0
 

Accepted Solution

by:
scrpl earned 0 total points
ID: 21799588
I managed to solve the problem. The sound/modem was disabled under power management when in battery mode. Turning it on solved my problem. Thanks anyway!
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Sometimes you have a CD / DVD drive that will not show up in Windows Explorer under My Computer.  There could be a number of reasons for this, which this article will discuss.   I will cover a few basic ways you can try to find the problem yourself.…
For some time some of our users experienced package loss on a couple of our Lenovo Thinkpad S531 machines running Windows 8 or Windows 8.1 64-bit OS. I was not able to find many answers online, but did after some investigation I began to suspect Blu…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question