Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1385
  • Last Modified:

FTP upload to OpenVMS using VB.NET

I am attempting to FTP a file with a specific format to an OpenVMS system, using the VB.NET FtpWebRequest object (see code snippet).  The strExportText string is given a value by opening a .txt file and reading in the contents.  The text file contains 3 lines of text.  The code below will successfully make the connection, stream the bytes, and end the connection.  When the file is opened on the OpenVMS side, the carriage returns are not being recognized.  There should be 3 lines of text, where now there is one continuous line with the letters CR and LF at the carriage return and line feed positions.  What settings need to be set in order for the OpenVMS to understand the characters?
Private Function ExportShipped(ByVal strExportText As String) As DBReturn
        Dim dbrReturn As DBReturn = DBReturn.Fail
        Dim ftpReq As FtpWebRequest
        Dim ftpStream As IO.Stream
        Dim bytExportText(strExportText.Length) As Byte
        Dim sdrSOExportInfo As SqlDataReader
        Dim strFTPDirectory As String
        Dim strFileName As String
        Dim strUserName As String
        Dim strPassword As String
        
        Try
            sdrSOExportInfo = mobjDBShipping.GetSOExportInfo()
            If sdrSOExportInfo.Read Then
                strFTPDirectory = sdrSOExportInfo(db_Shipping.SOExportIX.OutputDirectory).ToString
                strFileName = sdrSOExportInfo(db_Shipping.SOExportIX.OutputFileName).ToString
                strUserName = sdrSOExportInfo(db_Shipping.SOExportIX.Username).ToString
                strPassword = sdrSOExportInfo(db_Shipping.SOExportIX.Password).ToString
 
                ftpReq = FtpWebRequest.Create(strFTPDirectory & "\" & strFileName)
                ftpReq.Credentials = New NetworkCredential(strUserName, strPassword)
                ftpReq.Method = WebRequestMethods.Ftp.UploadFile
	       ftpReq.UseBinary = True
 
                bytExportText = Encoding.Default.GetBytes(strExportText)
                ftpReq.ContentLength = bytExportText.Length
 
                ftpStream = ftpReq.GetRequestStream
                ftpStream.Write(bytExportText, 0, bytExportText.Length)
                ftpStream.Close()
 
                'ftpResponse = ftpReq.GetResponse()
 
                '("Upload File Complete, status {0}", ftpResponse.StatusDescription)
 
                '  ftpResponse.Close()
                dbrReturn = DBReturn.Success
 
            Else
                dbrReturn = DBReturn.Fail
            End If
 
        Catch ex As Exception
            Throw ex
        End Try
 
        Return dbrReturn
    End Function

Open in new window

0
pprater1
Asked:
pprater1
1 Solution
 
jmfairchildCommented:
I believe that your problem may lie in the binary transfer. It has been awhile since I worked with VMS, but I believe you will have to FTP the file in ASCII format to ensure it gets read properly on the OpenVMS end. Try setting the UseBinary statement to ftpReq.UseBinary = False. If that doesn't work, or you can't use it for some reason, you will need to convert the file on the other (OpenVMS) end. If so, I could probably scare up an old DCL command file that would do the trick if you would feel comfortable with that solution.
0
 
pprater1Author Commented:
I ended up trying this before you posted and it is absolutely correct.  I used a combination of setting UseBinary = False and the Encoding in line #25 to ASCII.  Not exactly sure why it wanted straight text instead of binary, but it worked.  Thanks for your help!!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now