Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

SBS2003 DHCP server detects itself

Posted on 2008-06-16
16
Medium Priority
?
389 Views
Last Modified: 2012-06-27
i have an SBS server that is responsible for DHCP on my network. Every few hours the DHCP service shuts down stating that it has detected another dhcp server on the network. the problem is the DHCP server it is detecting is itself.
this SBS has 2 NIc cards

card 1 192.168.27.134, 255.255.255.224, 192.168.27.129
card 2 192.168.16.10, 255.255.255.0, (no gateway)

the error message states that SBS has encountered another server on this netowrk with ip address 192.168.16.10.

any ideas on how to fix this from the server side, without touching the actual network?
0
Comment
Question by:Sanga Collins
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 2
16 Comments
 
LVL 9

Assisted Solution

by:craigothy
craigothy earned 186 total points
ID: 21796196
Check your bindings within DHCP.  Launch the DHCP administration console.  Right click on the DHCP server in question and click "properties".  Click the "Advanced" tab and then click the "Bindings" button.  Make sure the inactive nic is not checked and the active nic is checked.  Hope this helps.
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21796294
the server is bound to the 192.168.16.10 address on NIC#2, but not to the 192.168.27.134 address. should it be bound to both interfaces or just the one that it is servicing?
0
 
LVL 9

Expert Comment

by:craigothy
ID: 21796355
It should only be bound to the network segment that it is servicing.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 18

Author Comment

by:Sanga Collins
ID: 21796451
it was bound to just the one interface (same as network it was serving)
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 21806948
Are you certain DHCP has not been enabled on a local router?
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21824964
dhcp is not enabled on the local router (actually a juniper firewall) i also blocked all traffic from the second NIC card from reaching the first NIC card using a policy in the firewall. sadly the result is the same. every few hours the dhcp server service shuts itsefl off saying that it has it has detected another server on the network, which happens to be itself
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 189 total points
ID: 21825043
Though it would not be enabled with a wizard, RRAS (Routing and Remote Access) has an option to install NAT/basic firewall. Within it's configuration it can set up a DHCP server for NAT clients which can cause the DHCP server to shut down. If RRAS is enabled try locating the RRAS service in the service management console and stopping the service to see if this cures the problem. If so RRAS will have to be re-configured.
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21826567
i stopped the RRAS service and should have more info by tomorrow morning whether it worked or not. This server is occasionally used as a VPN gateway into our network for my boss, and it looks like RRas is a part of that setup. hopefully my boss wont need to connect while he is on a week long business trip!
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 21826736
If you want to leave RRAS enabled you can locate the specific problem. I didn't have a RRAS server handy earlier. The problem, if it exists, is the DHCP allocator. This can be located and disabled by going to: RRAS console | expand the server name | expand IP routing | if present/installed right click on NAT and choose properties | Address assignment | un-check automatically assign IP addresses using DHCP allocator.
I can't think of anything on SBS this would be used for. It can be used when doing Internet Conection Sharing without SBS.
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21842954
i tried with RRAS disbaled, as well as with the dhcp allocator disabled (it was already disabled by default) and the problem persists. i think im just going to disbale the dhcp server entirelly and just let the juniper firewall handle the dhcp services from here on out.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 21843008
The only other possibility I can think of is to use a packet analyzer like Wireshark, filter for DHCP offers, and see if any are coming from another source.
http://www.wireshark.org/
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21847186
ill give this a shot before throwing in the towel. id rather fix the problem than just find a quick band aid (which happens alot at the company i work for, i think we have more band aid than actual infrastructure).

ill post the results later this evening or early tomorow
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 21847447
Great. Good luck with it.
I agree the band-aids pile up and then end up being the problem down the road.
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21878574
i finally resolved the problem by removing dhcp options 66 and 68 which were configured for a now defunct pxe boot server. im not sure why this started causing the problem, but since i removed the settings earlier this week, the problem has since stopeed
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 21879027
Interesting.
Good to know, and thank you for reporting your findings. Likely option 68 that was the problem.
--Rob
0
 
LVL 18

Author Comment

by:Sanga Collins
ID: 21899122
just to clarify for all, it was actually option 66 and 67 that i used,not option 68. i was also able to determine that i had missed some steps when configuring windows to point to a secondary serve for pxe boot services. in addtion to the DHCP options, RRAS needed to be configured as weel which i totally neglected.

thanks to all for your contributions
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever wondered why you had to use DHCP options (dhcp opt 60, 66 or 67) in order to use PXE? Well, you don't!
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question