• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1125
  • Last Modified:

Windows LAN Permissions Problem

On our LAN, several of the computers on it in the same workgroup, the problem is this:

Computer A can access computers B and C, computer B can access computers A and C, but computer C cannot access computers A or B.  But this computer (C), can use the internet, therefor the LAN itself does work.  When entering the workgroup an error message occurs:

"[Computer A] is not accessible.  You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions."

But this is bogus.  It was working fine just a while ago, and no changes were made to this computer by any administrator.
0
asaivan
Asked:
asaivan
  • 15
  • 15
  • 2
  • +1
1 Solution
 
LazarusCommented:
It's quite possible that a user profile has been corrupted. Are you using AD in your network? If so rename your user profile and let it rebuild a new one, the you can copy the docs and things from the old profile to it.
0
 
alikaz3Commented:
>>>"[Computer A] is not accessible.

Confirm that the "workstation" service is running on computer C. Right click my computer, then click manage. Then click services, scroll down to "workstation". It should say "started" and "automatic". Let me know!
0
 
gothicbloodyCommented:
Hello , your problem is most frequently caused by a misconfigured personal firewall, or other security component. so you have any firewall try to check your configuration or disable it temporarily


0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
asaivanAuthor Commented:
Hi, thanks for all of your responses.

lazarus98, we are not using AD as we are using XP Home on this network.

alikaz3, workstation is running and is set to automatic.

gothicbody, I turned off the firewall and tried to access the network, but to no avail.
0
 
alikaz3Commented:
try this:

Symptoms of the problem
When you try to access a Windows XP-based network computer, you receive an error message that resembles the following:
xxxxxxx is not accessible. You might not have permission to use this network resource. Access is denied.
Note In this error message, xxxxx is the IP address or the computer name of the Windows XP-based computer.

You may experience this issue when you use the IP address or the computer name to access a shared folder that is stored on the Windows XP-based computer. You may also experience this issue when you use My Network Places to access a shared folder in this situation.

Back to the top
Cause
This issue can occur if the Windows XP-based computer to which you are trying to connect is configured to restrict access over anonymous connections.

Back to the top
Steps to resolve the problem
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
To resolve this issue, set the value of the restrictanonymous registry entry to 0. To do this, follow these steps:
1.      Click Start, click Run, type regedit, and then click OK.
2.      Locate and then double-click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
3.      On the right side, double-click restrictanonymous.
4.      Make sure that the value in the Value data box is set to 0, and then click OK.
5.      Close Registry Editor.
6.      Restart the computer.







http://support.microsoft.com/kb/913628
0
 
alikaz3Commented:
and if that doesnt work try this:

Enable the IPX/SPX protocol and follow all instructions.
To enable file and print sharing on the IPX/SPX protocol
Only perform this procedure if your home or small office computers are connected directly to the Internet through individual connections or using a DSL or cable modem connected to an Ethernet network hub.

1. Open Network Connections.
2. In Local Area Network, Right click on top of your connection and select Properties, click Install.
3. In Select Network Component Type, click Protocol, and then click Add.
4. Click NWLink IPX/SPX/NetBIOS Compatible Transport Protocol, click OK, and then click Close.
5. In Network Connections, on the Advanced menu (on top menu bar), click Advanced Settings.
6. On the Adapters and Bindings tab, under Connections, click the local area connection on which you are enabling IPX/SPX file and print sharing.
Under Bindings for Local Area Connection, under File and Printer Sharing for Microsoft Networks, clear the Internet Protocol (TCP/IP) check box, and then click OK.


http://www.pctools.com/forum/showthread.php?s=8294af2bcf22bb89c3992abcd54c0370&t=33684&page=2
0
 
asaivanAuthor Commented:
alikaz3,

Neither work.  The second method though, does enable the network to be accessed, sort of, in that the computer can see itself as part of the network, but doesn't show any other computer on the network, nor can any other computer see it, when the second method is used.  Thank you, though.
0
 
LazarusCommented:
Asaivan, Yeah, sorry. I didn't read it very well, bit tired from a long day.
Have you tried removing the Computer from your workgroup and re-adding it into the workgroup? Also you may want to check all your TCP settings to make sure nothing is mistyped.
0
 
alikaz3Commented:
I remember dealing with an issue like this with XP back when SP1 was the newest... sometimes changing your sharing settings turning on/of simple file sharing, messing with microsoft file and printer sharing, got it to work; and on some machines, you had to reinstall... have you considered reinstalling xp on that machine?
0
 
asaivanAuthor Commented:
alikaz3,

Yes we are considering.  But the thing is, I've just reinstalled Windows on my machine (not the one in question) and I'm still having network troubles.  I can't access the workgoup itself, although I can access machines individually in the workgroup (make sense?) as they are listed in the My Network Places.

lazarus98,

You know, yesterday when I was messing around with this, I found that the network was not set right, and the actual network it was set to was something other than our network name, so I changed it to the right name, however I still have the problems.  I will try removing it from the network and reconnecting it.  But as alikaz3 says, we may have to do a reinstall, because I'm suspicious of spyware or some other type of malware living on it.  It's running very slowly in some instances, in other instances locking up, and I don't know why.

0
 
alikaz3Commented:
ok can you check a few things for me? make sure "simple file sharing" is disabled, in your folder options menu>advanced. Also, can you confirm that you are running SP3 on all machines? let me know!
0
 
asaivanAuthor Commented:
Where would I find simple file sharing?  I can't find it from Explorer.  No, SP3 is not installed.  I have it on my machine, but I believe no other machines have it.
0
 
alikaz3Commented:
open a folder, tools>folder options>view (scroll to bottom) "use simple file sharing"

if it is XP home you will not have this option, as simple file sharing is forced on.
0
 
alikaz3Commented:
also, what are your usernames/passwords for these systems like? are any of them blank passwords?
0
 
asaivanAuthor Commented:
No, they're all set up with normal usernames/passwords.
0
 
alikaz3Commented:
and are the usernames and passwords the same for all systems or different?
0
 
asaivanAuthor Commented:
all different
0
 
alikaz3Commented:
Ok I would suggest at this point to install all your updates. Download the standalone SP3 installer to save time:

http://www.microsoft.com/downloads/details.aspx?FamilyID=5b33b5a8-5e76-401f-be08-1e1555d4f3d4

Install this on all pre-SP3 machines, reboot, and give it another try.
0
 
asaivanAuthor Commented:
Ok, we'll try it out and post back soon. Within the next few days or so.
0
 
asaivanAuthor Commented:
Ok, news update.  No go.  I installed SP3 on all machines, and nothing.  I get the same errors on all machine when I try to access the workgroup from the Entire Network folder.  "Permission Denied."  AHHHH!
0
 
alikaz3Commented:
Ok I am leaning towards computer C having some bad network settings. Open internet options (through control panel), hit connections, then the LAN Settings button. Confirm that all boxes are unchecked. Also go to Network Connections, right click Local Area Connection > Properties. Single click Internet Protocol (TCP/IP)> Properties button, confirm that you have automatic for both settings on general tab.
0
 
asaivanAuthor Commented:
Ok, tried both.  All boxes were unchecked.  Although in the TCP/IP tab I had the DNS configured for primary to point to a local DNS server, then in secondary to point to the main DNS server which our ISP provides.  I unchecked it, but nothing.  When I click on the main network and look at the workgroup, on this computer (C), nothing shows up.  While in the other machines, I get a permission denied error.
0
 
alikaz3Commented:
Do you have any other security software that may have a firewall?
0
 
asaivanAuthor Commented:
This machine is using Norton Antivirus, Spybot Search&Destroy, LavaSoft AdAware....plus Windows Firewall...I'm not sure what else....I can check it out.  All the other machines are using the same except for Norton; using AVG Free instead.  I can check for more though.
0
 
alikaz3Commented:
Oh, lets try this too:

Open Network Connections
Right click LAN> Properties
TCP/IP > Properties
Advanced.... > WINS Tab
Pick "Enable NetBIOS over TCP/IP"
Restart
0
 
alikaz3Commented:
The AdAware and S&D are fine, you already ruled out windows firewall, Norton usually only has firewall if it is the Norton Firewall or Internet Security products.
0
 
asaivanAuthor Commented:
Nada....(thanks for helping us though)
0
 
alikaz3Commented:
No prob, ok so you tried the NetBIOS thing? What about reinstalling file and printer sharing, and client for microsoft networks?
0
 
asaivanAuthor Commented:
We could try.  Do we need XP Home CD for this?
0
 
alikaz3Commented:
I believe so.
0
 
asaivanAuthor Commented:
Ok, I'll get back to you.
0
 
asaivanAuthor Commented:
Tell me I'm not crazy. No, Windows is crazy.  For whatever reason, I can see all the computers on the network again, as well as the Macs.  The other computer which was having the main problem seems to be fine now.  The weird thing is, we didn't change anything!  NOTHING!  AAAAAAHHH!

I don't know, but thanks alikaz for your help.  I'll assign you points for a partial answer, primarily for your helping us out.
0
 
asaivanAuthor Commented:
I don't know if this was the real answer or not, but I'm assigning points anyway for the assistance rendered.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

  • 15
  • 15
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now