• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1817
  • Last Modified:

Remote desktop not working on VMware

I have a VMWare v 3.0 server with 4 instances of Windows Server 2003 R2 and one of the virtual servers can only be accessed through the VMWare client. I checked to see if Remote Desktop is turned on and it is but when I run netstat -a I don't see it listening on the RD port.  I don't know what could be blocking it.
0
m-moloney
Asked:
m-moloney
  • 9
  • 3
  • 2
  • +1
1 Solution
 
larstrCommented:
Is the "Terminal Services" service started?
net start "Terminal Services"

Lars
0
 
m-moloneyAuthor Commented:
Yes the reply to the net start command is " The requested service has already been started"
0
 
larstrCommented:
And you have enabled it in System / Properties / Remote / Remote Desktop ?

From the command line of your Windows guest, please show us the output of the command:
netstat -an|find ":3389"


Lars
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
m-moloneyAuthor Commented:
It just returns to the prompt.
0
 
m-moloneyAuthor Commented:
Yes, it is enabled under the remote tab of the system applet.
0
 
m-moloneyAuthor Commented:
Could other ways of remotely connecting to the server cause problems with RD?  One of the admins uses damewear.
0
 
m-moloneyAuthor Commented:
Has anyone heard of problems with RD and VMWare 3.0?
0
 
larstrCommented:
A virtual machine is very much like a physical one even if one of the other admins is a cross dresser ;)

By VMware 3.0 I suspect you mean ESX 3.0.x (and not Workstation 3.0 which is very old). The networking on ESX operates at layer 2 and is not able to block any such services and there shouldn't be any VMware specific reasons that RDP is not working.

This is probably more of a windows problem than anything else.
0
 
m-moloneyAuthor Commented:
yes, esx 3.0x.  I have 3 other virtual servers on this same box and they are not having trouble with RD.  I have the same GPO's applied, etc.  I had this same trouble with one of the other virual servers but a reboot fixed it. I will get into the server a get a list of software running. Maybe one of those is causing the problem.
0
 
jfields71Commented:
Did you check the Windows Firewall on the VM?  It may not be listed as an exemption, even though you have enabled the service.  I have seen this happen before.  Start --> Run --> firewall.cpl --> Exemptions tab.  
0
 
m-moloneyAuthor Commented:
The firewall is disabled.
0
 
Casey HermanCommented:
check local policy on the server
gpedit.msc

then check this

Computer Configuration/Administrative Templates/Windows Components/Terminal Services

Enable - Allow users to connect remotely using Terminal Services

Casey
0
 
m-moloneyAuthor Commented:
It is already set. I checked that first.
0
 
Casey HermanCommented:
are you running antivirus on that vm?
0
 
m-moloneyAuthor Commented:
I figured it out.  There was a missing key in the registry under the hklm\system\curentcontrolset\control\terminal server\winstations\  all it had was the console key not the RDP-Tcp  key. I copied it from another server and it started working.
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 9
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now