Main website url is not working but all the other supporting urls are working ?

i have site called www.mysite.com ( this is not working )

While this site is a cluster of www1.mysite.com and www2.mysite.com ( both are working)


Both are linux machines ..where is the proplem.. both are integrated apache tomcat
jaisonshereenAsked:
Who is Participating?
 
objectsConnect With a Mentor Commented:
check your dns, it defines what ip maps to your server name

0
 
jaisonshereenAuthor Commented:
ping result from an outside windows server give an different ip x.x.x.92

where ifconfig of linux server is giving x.x.x.61
0
 
objectsCommented:
sounds like the problem is with your apache config

0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
jaisonshereenAuthor Commented:
There are a list of ip in allow from field ..

which ip i need to give there?
0
 
jaisonshereenAuthor Commented:
ExtendedStatus On
<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from 10.0.0.0/255.0.0.0
    Allow from *.155
    Allow from *.2
    Allow from *.150
    Allow from *.59
    Allow from 127.0.0.1
</Location>
0
 
jaisonshereenAuthor Commented:
which httpd.conf file i have to check ? www1 or www2 or cluster?
0
 
objectsCommented:
hard to say without more info. whats the response when you request www.mysite.com
Is the request getting to apache?

0
 
jaisonshereenAuthor Commented:
i change my ip from *.92 to *.61

and after change when i ping www.mysite.com i am getting *92  ..actually it should be *.61

iftables is resulting *.92

0
 
objectsCommented:
sounds like your dns is wrong? you need to get it pointing at the right box 1st
0
 
jaisonshereenAuthor Commented:
i reverted the server ip from *.61 to *.92

now website is working..

www.mysite.com is working only with *.92 ...

how to check dns? where is this entries ? and where to edit?

i have a softlayer login where all manages servers..
0
 
objectsCommented:
> www.mysite.com is working only with *.92 ...

what do u mean?

> how to check dns? where is this entries ? and where to edit?

check with your system administrators

0
 
jaisonshereenAuthor Commented:
> www.mysite.com is working only with *.92 ..

means .. when i changed to *.92 only its worked
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.