Looking for specific instructions on sending email from Exchange Server

I have an SBS2003 with Exchange 2003 server running, and am unable to configure outgoing SMTP service. I am currently using my external webhost's POP and SMTP server to receive and send email for my hosted domain, but would like to configure the Exchange Server to do so. I understand that I need to enable and turn on the SMTP and POP3 connectors, but so far have been unsucessful in using them. My ISP is Comcast, if that makes a difference.

I have read numerous threads on this topic, but specific details seem to be missing, or at least eluding me.

Thanks in advance... Rich
RichAsked:
Who is Participating?
 
DocCan11Commented:
well me know know that your computer IS able to resolve regular DNS lookups.. I would think that it should have no problem with this either but this will check if the MX record exists for your domain

type nslookup <enter>
set querytype=MX <enter>
mail.gagnonconsulting.com <enter>

 you should get a response that is your IP address .. if this is not correct we have found our problem
0
 
DocCan11Commented:
Setting up Exchange to send. (you use connectors to deliver mail)
1)make sure that your server has working DNS.. so it can query and resolve any internet address..
2) in Exchange System Manager, click on connectors and choose new SMTP connector, give it a name (really doesnt matter), if you leave it on the default choice of "Use DNS to route to each ..." then your Exchange server will attempt to deliver all its own mail directly to the destination servers.. If you choose "forward all mail through this connector.." then you would put the FQDN name of your ISP's mail server.. all mail will then be forwarded to them and they will deliver it for you .. Much like is being done right now..
3)click on the Address space tab, click add, then choose SMTP.. leave the default domain as "*" this mean this will be used for all outgoing mail.. you can create SMTP connectors for each unique domain you want to deliver to but it is not necessary..

Mail should now be flowing OUT of your exchange server the the internet..

To receive Mail.. (use SMTP virtual servers to receive mail)
1) In exchange system manager select, open servers, your server name, protocols, SMTP.. this is how you configure to receive mail... the truth is the default setting should be fine and allow you to receive email from the internet..
2) you will need to find who hosts the DNS records for your domain and have them point the MX record to the IP address of your Exchange server..

You are not ready to send and receive mail.. You will next need to setup the mailboxes on your exchange server for your users.. If you want them to be able to get the mail by using POP3 you will configure the POP3 virtual server as you did the SMTP above..

Let me know if you need more info
0
 
RichAuthor Commented:
Thanks for the quick response. I will try this when I get back in the office later this evening. One issue I see is that I will need a static IP for my server (I have a reasonably stable dynamic IP here.)
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
DocCan11Commented:
yes you will.. OR you can use DDNS.. or Dynamic DNS.. you will need to move your DNS domain to be hosted on a site that provides this service, then if your IP address changes your server will update its record on the DNS server and people will be redirected to the proper location.. I should warn you that because of caching it is possible that people will try and deliver mail to your old IP.. you will need to tell the hosting DNS to set your TTL to a very low number


0
 
RichAuthor Commented:
Hi DocCan11
I set up the SMTP outgoing connector as you described, and set Outlook to use the Mailbox account on the Exchange Server to send email (verses my external account). I have created and sent two messages, and have tried to get them to go with both with the server set to send directly, and to send using mail.gagnonconsulting.com email server, which I usually use.
Now, in the Exchange Manager Queues, I have, amoung others, a queues with a little folder with a closed folder and what looks like a little blue shortcut arrow, called Gagnon Consulting Mail - mail.gagnonconsulting.com (SMTP Connector). It has two messages in it, both which I tried to send to gagnonconsulting@yahoo.com. It appears to not be not sending, as it has retried several times.
0
 
DocCan11Commented:
the queues are normal, this is where exchange holds mail while it is trying to deliver it.. so the good side is exchange is working well.. now we have to find out why it is not connecting externally..

from the command prompt on the exchange server I need you to type the following commands and let me know the response..

nslookup mail.gagnonconsulting.com
nslookup www.google.com

I am trying to see if you can use DNS on your exchange server
0
 
RichAuthor Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>nslookup mail.gagnonconsulting.com
Server:  dell-2900.gagnonconsulting.local
Address:  192.168.1.2

Non-authoritative answer:
Name:    gagnonconsulting.com
Address:  216.122.218.6
Aliases:  mail.gagnonconsulting.com


C:\Documents and Settings\Administrator>nslookup google.com
Server:  dell-2900.gagnonconsulting.local
Address:  192.168.1.2

Non-authoritative answer:
Name:    google.com
Addresses:  64.233.167.99, 72.14.207.99, 64.233.187.99


C:\Documents and Settings\Administrator>
0
 
RichAuthor Commented:
That is the correct IP in the MX record for the mail server

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>nslookup
Default Server:  dell-2900.gagnonconsulting.local
Address:  192.168.1.2

> set querytype-MX
> mail.gagnonconsulting.com
Server:  dell-2900.gagnonconsulting.local
Address:  192.168.1.2

Non-authoritative answer:
Name:    gagnonconsulting.com
Address:  216.122.218.6
Aliases:  mail.gagnonconsulting.com

>
0
 
RichAuthor Commented:
I have just tried it with the mail server set to smtp.comcast.net, which is the mail server of my ISP. It did not work either. Same thing. Is there a place to look for a specific error response message?
0
 
RichAuthor Commented:
Actually, what I have found is that my domain user RichardGagnon, has an email address set in the AD User Properties of RichardGagnon@mail.gagnonconsulting.com, whereas I would want Richard@gagnonconsulting.com. I am not sure if this would cause the not sending issue, but if it does work, it will have the wrong email sender. Although this is s different thread, I have changed the email address in the AD and it changes unitl I close the Active Directory Users and Computers, but is back to RichardGagnon@mail.gagnonconsulting.com when I open the control and view the user properties again.
0
 
RichAuthor Commented:
OK, I found that there are 3 email addresses with type SMTP for my user. I have set the Richard@gagnonconsulting.com as the Default SMTP, but the other two, RichardGagnon@gagnonconsulting.local and RichardGagnon@mail.gagnonconsulting.com are still there.
0
 
RichAuthor Commented:
Thank you very much for your prompt help with my issues.

I figured it out. Turns out Comcast, my ISP is blocking port 25, and I have to user port 587. So I had to set the smarthost to smtp.comcast.net, and then in the Default connector, I had to set the port to 587, and a Comcast username and password. Then I had to delete my SMTP connector and recreate it, setting everything except the 587 - there was no place to set it here - apparently gets it from the default connector??? Strange, since the other advanced delivery settings from the default connector did not come over when I created the SMTP connector. I had to put the comcast usename and password there, too.

As far as the SMTP email sent from address, I had to create a new recipient policy and tell it to use
%g@gagnonconsulting.com as the SMTP email address to get Richard@gagnonconsulting.com as address. According to MS Tech notes, I should not change the default recipient policy, which was where it was getting the RichardGagnon@mail.gagnonconsulting.com (though) I cleaned that up to remove all SMTP rules except the @gagnonconsulting.local, which was automatically created when I set up the server.

Rich
0
 
DocCan11Commented:
I am glad you found the issue.. my next step would have been to check for port 25 connectivity.. :)
0
 
RichAuthor Commented:
Thanks. Just for the heck of it, how would I have done that? Also, I have one more (hopefully quick) question. Now I can send emails, but they are not showing up in the Sent items folder of my mailbox. Any ideas?
0
 
DocCan11Commented:
I would have had you go to the command prompt and type the followiing

telnet 25 somemailserverdnsname

This would have allowed you to check if you could get to port 25 of the smtp server..
0
 
RichAuthor Commented:
Thanks for that info. I learn something new every time! By the way, the sent emails started showing up in the Sent box all on their own. I lost a handful, but they are showing up there now.

It was great working with you.
0
 
DocCan11Commented:
my pleasure.. any time
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.