Getting an authorize.net connection failure

Hi.  I've been battling this for awhile now and need help.  I have a shared godaddy host account with coldfusion installed.  I also purchased at godaddy and have setup a "Standard Multiple Domain (UCC) SSL Up to 5".  I set up multiple domains on the host account (using sub domains) so those domains are pointing to subdirectories off of the root.  I then created ssl subject alt names to each of those domains in the certificate.  so I have:

Shared host account.  coldfusion installed.
www.siteone.com -> /siteone.com
www.sitetwo.com -> /sitetwo.com
www.sitethree.com -> /sitethree.com

The certs have been apparently setup properly and no errors show in the browser (IE), I see the 'lock' on the https pages and when clicked, it properly displays the certificate (when viewing the cert further, it of course displays the owner of the actual cert which is my company).  So, all of that looks and functions properly.

However, I also have an Authorize.net account and am using AIM (using the cf_aim file).  All the settings are correct including the tran key and login id.  However, I get a 'Connection Failure' error when I run the test page.  I have another shared host account with godaddy and have a regulare ssl cert applied to just that host account.  I've tested it and it runs perfect?  I'm using the exact same test page.  Does it have to do with the UCC 5-pack ssl cert and me using subject alt names?  Please someone help me.  I'm pulling my hair out!
COwebmasterAsked:
Who is Participating?
 
SidFishesConnect With a Mentor Commented:
try this on a test page

<cfhttp method="post" url="https://secure.authorize.net/gateway/transact.dll" name="test">
<cfhttpparam name="merchantid" value="Test" type="formfield">
</cfhttp>

<cfoutput>#test.filecontent#</cfoutput>

it works for me.
0
 
SidFishesCommented:
0
 
COwebmasterAuthor Commented:
Hi SidFishes.  I can't even connect using http at least on the one account.  It works on the other account using http, but not the other.
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
COwebmasterAuthor Commented:
I'm pointing the params to <cfhttp method="post" url="https://secure.authorize.net/gateway/transact.dll">
0
 
SidFishesCommented:
when I say works i mean I get  an authorize.net error message, but that is valid as I am not passing proper params
0
 
COwebmasterAuthor Commented:
It takes a long time to get a response (30 seconds), then I get an error:

Element FILECONTENT is undefined in TEST.
0
 
COwebmasterAuthor Commented:
I tried that in my other shared hosting account which connects fine and an immediate response came back..

The column name "
The following errors have occurred.
(13) The merchant login ID or password is invalid or the account is inactive.
" is invalid.
0
 
SidFishesCommented:
hmm... works for me in  <2 secs

try loading it in the browser by clicking on the link
https://secure.authorize.net/gateway/transact.dll

0
 
COwebmasterAuthor Commented:
I get an immediate response..

The following errors have occurred.
(13) The merchant login ID or password is invalid or the account is inactive.
0
 
SidFishesCommented:
then it must be the cert store

did you try this from the livedocs link

"To use HTTPS with the cfhttp tag, you might need to manually import the certificate for each web server into the keystore for the JRE that ColdFusion uses. This procedure should not be necessary if the certificate is signed (issued) by an authority that the JSSE (Java Secure Sockets Extension) recognizes (for example, Verisign); that is, if the signing authority is in the cacerts already. However, you might need to use the procedure if you are issuing SSL (secure sockets layer) certificates yourself.
To manually import a certificate:

   1. Go to a page on the SSL server in question.
   2. Double-click the lock icon.
   3. Click the Details tab.
   4. Click Copy To File.
   5. Select the base64 option and save the file.
   6. Copy the CER file into C:\CFusionMX7\runtime\jre\lib\security (or whichever JRE ColdFusion is using).
   7. Run the following command in the same directory (keytool.exe is located in C:\CFusionMX7\runtime\jre\bin):

      keytool -import -keystore cacerts -alias giveUniqueName -file filename.cer

0
 
COwebmasterAuthor Commented:
i'm on a shared hosting environment with godaddy and believe have zero access to do any of that.  I bought the cert through them (starfield) and they set it up.
0
 
SidFishesCommented:
your SSL cert is irrelevant for use with cfhttp. Your ssl cert is is to encrypt data between your server and your clients browser. cfhttp is acting as a browser client on your server connecting to the SSL server on authorize.net.

I have seen a bunch of posts regarding godaddy/authorize.net and php shopping carts. The solution was to use a proxy, but I've seen nothing on using cfhttp

I think you will probably have to open a support ticket with godaddy as I don't think there is anything you can do from your end.

0
 
COwebmasterAuthor Commented:
but it works for my on another godaddy shared hosting account I own?
0
 
SidFishesCommented:
your one site may be running on a different cf server as I expect they have dozens if not 100's
0
 
COwebmasterAuthor Commented:
that could be. I believe the one I'm one uses cf 7.  would that make a difference?
0
 
COwebmasterAuthor Commented:
Could it be that godaddy is blocking the gateway ip for authorize.net on that machine and that is why I can connect to them?
0
 
COwebmasterAuthor Commented:
what is strange is that one time it was working until I purchased an ssl cert and had them set it up.  After 6 weeks, they realized the host account was improperly setup.  what does that mean?  does that also mean the coldfusion wasn't setup properly or that they blocked the authorize.net gateway ip?
0
 
SidFishesCommented:
at this point, I'm not sure I've any more suggestions except talk to tech support... sounds like they may have screwed something up.
0
 
COwebmasterAuthor Commented:
thanks for your hekp on this.
0
 
COwebmasterAuthor Commented:
I have to use a proxyserver in the cfhttp tag I'm finding out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.