Solaris 10 display 'fuzzy' through APC KVM Switch

We have a Solaris 10 box connected to an APC KVM Switch (via the APC 'Sun Console Converter' KVM cable)

The display is barely readable with a 10mm horizontal flicker

Thinking that it's a resolution issue.
ivan_sandersAsked:
Who is Participating?
 
pramodzplanetCommented:
To change the console resolution and/or refresh rate, at the EPROM command prompt enter:
setenv output-device screen:r1152x900x76

The above command sets the console to 1152 x 900 at 76 Hz.
0
 
omarfaridCommented:
what type of monitor and its capabilities (resolution / freq.)? What server / system are you using to run solaris 10 on?
0
 
ivan_sandersAuthor Commented:
Monitor is AP5017

1280 x 1024 maximum resolution
Input Frequency        50/60 Hz

Server is Sunfire V440
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Brian UtterbackPrinciple Software EngineerCommented:
How long are the cables used? High resolution monitors are highly susceptible to electrical interference from the cables. Anything longer than about 4 feet can require highly shielded cables. Not always, as I said, it depends on the environment and the resolution.
0
 
ivan_sandersAuthor Commented:
It would be (probably) 1.5m - but designed for the rack mount situation - so I would have thought the cable design would have been ok..   My thought was something to do with the resolution..   How can I check what the configured resolution on the Sun box is?...

Though the APC KVM does I think try and match the output of the box..   When I switch to the Sun output, the KVM displays "New Mode detected 1192x892 66Hz"
0
 
Brian UtterbackPrinciple Software EngineerCommented:
Sometimes the problem is that the KVM does not pass the correct display info to the box when it is booting and the display is not directly connected at the time. I have a KVM and if a system reboots while it is not connected to the display, it incorrectly reads the display type and resolution. In my case I was able to work around this by hard-coding the display info in the xorg.conf file, but I am using a X86 based Ultra 40. On the sparc systems the X server is still Xsun and doing the configuration for that is trickier and frame buffer dependent. Are yo uusing sparc and if so, what type of frame buffer?
0
 
ivan_sandersAuthor Commented:
Sunfire V440 - starting to stretch me - how do I identify frame buffer??
0
 
Brian UtterbackPrinciple Software EngineerCommented:
Not entirely sure myself. The V440 did not come with a graphics card in the standard configuration, so no help there. There are a few of the newer XVR cards qual'ed, and one of the PGX64 cards. I think the pgx64 card is configured with the m64config command. IIRC, the XVR cards use fbconfig.
0
 
ivan_sandersAuthor Commented:
both the commands are there and produce output..
0
 
Brian UtterbackPrinciple Software EngineerCommented:
With fbconfig, you can use the -propt and -prconf options to display the current hardware and software configuration. Also -res will display the current resolution. It also has a -gui flag that lets you configure it all through a gui; try that.

The m64config command likewise allows you to set various resolutions.

There is also a pgxconfig command that might be relevant.   I suggest you read the man pages and give them a go. But first, try rebooting with the monitor connected to the rebooting system all the time during the process. See if you get any better results that way.
0
 
ivan_sandersAuthor Commented:
Interesting stuff - If I connect the KVM and reboot, I get the fuzzy output (and the KVM "New Mode detected 1192x892 66Hz")

If I reboot with the Sun Monitor connected, the display looks great - and then if I disconnect the Sun Monitor, and connect up the KVM monitor, the KVM Monitor looks great too (displays  "New Mode detected 1280x1024 60Hz")

The output of the fbconfig -propt is:

--- OpenWindows Configuration for /dev/fb ---

OWconfig: machine
Video Mode: NONE
Depth: 24

Screen Information:
      Doublewide: Disable
      Doublehigh: Disable
      Offset/Overlap: [0, 0]
      Output Configuration: Direct
      Fake8 Rendering: Disable
      Gamma Correction: no

The output of prconf is:


--- Hardware Configuration for /dev/fb ---

Type: XVR-100
ASIC: version 0x5159            REV: version 0x3000000
PROM: version 2.3

Monitor/Resolution Information:
Monitor A:
      EDID Data: Not Available
      Current resolution setting: 1280x1024x60
      Current depth: 24
Monitor B:
      EDID Data: Not Available
      Current resolution setting: 1152x900x66
      Current depth: 8

Depth Information:
      Possible depths: 8, 24

The output of gui was that it was 'ambiguous'

Hoping the connection of the Sun Monitor and swap might twig something...

0
 
Brian UtterbackPrinciple Software EngineerCommented:
Okay, so the problem is that the KVM is not passing the monitor characteristics to the Xserver when it starts up. The Xserver sees a 1192x892 66Hz monitor with the KVM, but it should see a 1280x1024x60 monitor. So, the trick is going to be to hard code the resolution for that monitor to override what the KVM says. Or, always have the monitor connected when the Xserver starts.
0
 
ivan_sandersAuthor Commented:
that's about it - bloody big monitor taking up space just for when the Xserver starts - I like your first option
0
 
pramodzplanetCommented:
To set the resolution, run the following command as root :

# eeprom output-device=screen:r1280x1024x76

then reboot.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.