qemu on ubuntu 8.04 giving error VFS:Cannot open root device "hda" or unknown-block(0,0)

I am running following command:
sudo qemu  -m 32 -kernel data/linux-2.6.23/arch/i386/boot/bzImage -append "root=/dev/hda" -hda linux_i386.img  -boot c
it gives me following error in qemu window:
VFS can not open root device "hda "

please append correct root= boot option  

kernel panic:not syncing :VFS :Unable to mount root fs on unknown-block(0,0)
hirakpatelAsked:
Who is Participating?
 
MicheleMarconCommented:
Take a look here (jump to "create the environment")

http://ubuntu-tutorials.com/2007/07/04/setting-up-qemu-kqemu-on-ubuntu-704-feisty/

You basically need to create the virtual hard disk where the virtualized PC will live.
If you downloaded the .img file you need to insert this file on the command.
0
 
MicheleMarconCommented:
Have you prepared the linux_i386.img image file?

qemu-img create ...
0
 
hirakpatelAuthor Commented:
I am using it from sit called free electrons to leran kernel programming.
how to check linux_i386.img ?
how to use qemu-img create ...?
REMEMBER:I am using kernel parameter and giving linux kernel image which I build for pentium pro processor.
0
 
pointerstopCommented:
I don't know qemu, but I do know disks, and /dev/hda is a _disk_, not a partition.  Booting from a normal disk, you would need to use /dev/hda1 (or hda2 for the second partition, etc)
0
 
hirakpatelAuthor Commented:
thanks everyone I got solution I have to enable ramfs support in kernel.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.