• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 761
  • Last Modified:

Cannot VNC onto Virtual Machine over VPN

I have a Windows 2003 standard R2 host server with a Windows XP guest VM. This VM does everything I need, and should I need to access it I use VNC, its setup so somebody else can VNC it also, but they do not have access to anything else.
The problem I am having is that when I dial into my network remotely, I cannot VNC the VM. When I try to ping it, I get the first response and the nothing after that.
The VMware host server is also the RAS server which controls remote VPN on its 2nd NIC.
The guest OS/VM is running on bridged networking, with a static IP address.
Any ideas on how I can get VNC to work with this whilst over remote connection would be appreciated.
0
forzaaw
Asked:
forzaaw
  • 5
  • 4
  • 2
  • +1
2 Solutions
 
larstrCommented:
2nd nic? Maybe you will need to enable routing (ip forwarding) on your host os (RRAS)?

0
 
mrroonieCommented:
check the firewall on the XP/VM is disabled or at least configured to allow VNC through (normally port 5900)
0
 
forzaawAuthor Commented:
larsrt - The 2nd Nic is just for VPN clients to connect to.
mrroonie - The firewall service on the XP machine is disabled and I can connect to it when im on the LAN.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
mrroonieCommented:
are you trying to connect VNC via hostname or ip address? are the 2 NIC's on a different subnet?
0
 
forzaawAuthor Commented:
I have tried via host name and IP, same with my test ping. Both NIC are on the same subnet, 192.168.26.x
I can connect to all non VM computers fine, and I can RDP onto the host virtual server via internal and VPN connections.
0
 
mrroonieCommented:
what VNC are you using? have you tried any others? -
RealVNC - www.realvnc.com
TightVNC - http://www.tightvnc.com/
UltraVNC - www.uvnc.com
0
 
mrroonieCommented:
this may help - http://www.petri.co.il/virtual_using_vnc_and_vmware_server.htm

talks about editing the VM's VMX file halfway down, apparently this needs to be edited before VNC will work
0
 
forzaawAuthor Commented:
Sorry may be i worded my question wrong initially. I have tried the VMX edit before coming here, but i guess its not VNC related due to the fact pinging it only generates 1 reply, then no response...
0
 
larstrCommented:
Does your host or guest have more than 1 def gw? Should have only 1.
0
 
S00007359Cloud Engineering OfficerCommented:
If you are using a standard MS VPN, then you have make sure that your VPN's default gateway is ticked off. to do so:
1) Disconnect from the vpn if you are.
2) Click on the VPN Properties, and select the networking tab
3) Select TCP/IP, and click on properties, then click on advanced.
4) Untick use the default gateway on remote network, click on all ok's.

Give that a try, i beleive that's whats happenning!
0
 
forzaawAuthor Commented:
I will give these solutions a try and let you know the results, thanks.
0
 
forzaawAuthor Commented:
Fixed this myself, network setup issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

  • 5
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now