Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1676
  • Last Modified:

Not a terminal

Please see the error we are getting for the script
Not a terminal
stty: : Not a typewriter
stty: : Not a typewriter
^M^M    ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2     ^[2^M
                                                                 ^M/usr/lib/dld.sl: Can't open shared library: /project2/OES/634/src/oes/src/lib/libncro2.sl
/usr/lib/dld.sl: No such file or directory
/usr1/local/bin/nsrpre_express_backup[9]: 28180 Abort(coredump)

How can we get rid of the "Not a Terminal"?
1. We are running a cronjob script
30 00 * * * /usr1/local/bin/stop_start.sh > /tmp/stop_start_.log 2>&1
2. The stop_start.sh contains
#!/bin/ksh
#
# Procedure to stop/start instance on the weekends
#
/home/user1/.profile
#
/usr1/local/bin/nsrpre_express_backup
sleep 300
/usr1/local/bin/nsrpost_express_backup

3. /home/user1/.profile contains
# @(#)B.11.11_LR

# Default user .profile file (/usr/bin/sh initialization).

# only execute if interactive session

# Set up the terminal:
        if [ "$TERM" = "" ]
        then
                eval ` tset -s -Q -m ':?hp' `
        else
                eval ` tset -s -Q `
        fi
        stty erase "^H" kill "^U" intr "^C" eof "^D" susp "^Z"
        stty hupcl ixon ixoff
        tabs
export ORACLE_BASE=/usr1/oes
export ORACLE_HOME=$ORACLE_BASE/6.3.4.0
export OLAP_HOME=$ORACLE_HOME/olap
/home/oesdba/admin/scripts/stop_task_processors
sleep 600
# Stop the first instance of Express
/usr1/oes/6.3.4.0/olap/bin/oesmgr stop immediate ExpSrv634
sleep 120
# Stop the second instance of Express
/usr1/oes/6.3.4.0/olap/bin/oesmgr stop immediate ExpSrv634_1
# Allow 2 minutes for both the instances to stop.

Please advise









0
oo07
Asked:
oo07
1 Solution
 
DavidSenior Oracle Database AdministratorCommented:
This is caused by the 'stty' settings you have in your user profile (either ~/.profile or /etc/profile).  Try commenting them out and then login again.

Some people put stty commands in their startup scripts (.profile for ksh). Ideally, they should test to see if the shell is interactive.

0
 
oo07Author Commented:
we need the .profile to set the environment
0
 
DavidSenior Oracle Database AdministratorCommented:
Perhaps if you tried adding to your .profile the line ENV=~/.shrc  where .shrc contains your aliases and stty settings....
0
 
omarfaridCommented:
you may add an if statement in your .profile that checks your TERM env variable before calling stty
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now