WCF - Disable security

How do you disable security in WCF.  I have tried to disable it but am still getting "caller not authented by the service"

My binding looks like this
  <basicHttpBinding>
        <binding name="basicHttpBinding" closeTimeout="00:30:00" openTimeout="00:30:00"
          receiveTimeout="00:30:00" sendTimeout="00:30:00" maxBufferSize="655360"
          maxReceivedMessageSize="655360">
          <readerQuotas maxArrayLength="10000" />
          <security mode="None">
            <transport clientCredentialType="None" />
            </security>
        </binding>
      </basicHttpBinding>
LVL 3
Kevin RobinsonPrivate VB.NET ContractorAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Gautham JanardhanConnect With a Mentor Commented:
the same shud be done @ the server side also... if server is expecting some sort of security then u will get this error...
0
 
Gautham JanardhanCommented:
have u changed @ both ends client and server ?
0
 
Kevin RobinsonPrivate VB.NET ContractorAuthor Commented:
Yep.  Well I updated my service reference.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Kevin RobinsonPrivate VB.NET ContractorAuthor Commented:
I have manually checked through the Client and server side and security is turned off.
0
 
Kevin RobinsonPrivate VB.NET ContractorAuthor Commented:
Can I manually create the service references?  Sometimes they dont always map correctly to the service.
0
 
Gautham JanardhanCommented:
u can create  a clinet class tusing the svcutil tool and then use this to acesst the service..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.